Fax Software

Community Forums

#6749

JohnD
Participant

@rjonkman wrote:

First of all: I have had no luck reinstalling just the system part of winfax

I was referring to the output problem, not the missing printer driver. Its possible that the output problem only occurs in the application you are using, and not other applications.

I have just tested with word; It prints just fine, though, one may argue that word might send the data to be printed as a single image, which doesn’t need any recalibrating. The program works a bit differently–
Consider the page to be printed a ‘canvas’ on which lines of text will be drawn. The location of such a line is defined by it’s starting coordinates; for example, a line may start at (1000,1000) which brings the start of the line 1000 pixels from the left and 1000 from the top.
The problem now, is caused by a difference between the size of this canvas reported at the start; consider the width and length of the document to be 2000×3000 pixels. if the document is spaced and lined out on this number, but it’s in reality a lot more, say 2000×6000 pixels, the distance between lines will be about twice as big, and the document now takes 2 pages to print.
Something like this is currently happening at the computer we are using.

Symantec claims incompatibility with Windows 2000 Advanced Server (they don’t recommend WinFax being used on it)

You are right, I was under the impression it was supposed to work because of this document. After a little querying on account of your post i found this
one, which indeed states this incompatibility/unrecommended situation. I can only hope this doesn’t make it unresolvable.

Does this app have to run on the server? have you tried using it on another test machine to see if you get similar results?

It has run successfully on both windows xp (after some tweaking on the timing) and windows 98 (winfax 9) in the past.

At this moment, there is no computer available which can be accustomed to this task. If the problem persists, this might be the course of action to take. It’s either that, or looking for another faxing solution with scripting posibilities.

At this moment, I’m trying to solve the problem by modifying the program to use a fixed size for the canvas. It’s less generic code, but it should do the trick for this specific problem. The fact that the ‘printer’ is gone at every restart would ofcourse not be solved by this.

Both documents indicate incompatibility with Windows 200x Advanced Server (check the notes in the first document). I would recommend trying it on another machine if you can. It would probably save a lot of headache of trying to troubleshoot this. Even if you do modify your code to print properly, if anything changes (like the OS) or you move the app to another machine at a later time that modified code may not work properly on the new machine. You’ll just have to make note of this and remember what changes you did…

The missing printer driver that you reinstall at each boot up may be the cause of the printing problem, or it may not be. Until you can fix that problem, you can’t really tell if thats the case. This may be one of the incompatibility problems with Windows 2000 AS, but this problem was known to occur in Windows XP as well!

Have you tried reverting back to version 10.0 instead of 10.03??? This is a possibility to correct any problems. Do not use 10.02!

Also, Microsoft Fax that is built into Windows 2000 and Windows XP does have a Fax API. This is an possible alternative, plus you wouldn’t have to pay for the software since its already included with Windows.