Fax Software

Community Forums

#6767

kambrose
Member

I had to contact technical support as a result of their “known issue”. When I install it tells me I am installing 10.03 and gives me the same in help->about