Fax Software

Community Forums

#6805

Anonymous
Member

The saga continues…

I did get PCAnywhere to work. It was the “load with windows” check box that fixed it. Back to Winfax…

I did a reinstall of Winfax (10.03 now) with 1 Com port & 1 modem – all under the same admin user.

For troubleshooting, I chose to start the controller manually (durng setup) and I also installed a 33.6 external modem which has all the TX RX status lights.

When I boot the machine, and I’m at the login screen, the modem status lights indicate “ready to receive” as the Winfax service initializes in the background. Only the service is loaded at this point and it does indeed receive faxes before logging on. Great.

I continue to log on as a user, the modem is still ready. (Note that the controller is NOT running.) If I immediately log back off, the modem is still good to go & it receives faxes after I’ve logged off. Very good.

Up to this point, I can receive faxes before logging on and I can receive faxes after logging back off. Note that I have not yet started the controller at all yet – not even once.

Now I add the controller to the mix:

I log on, and I start the controller. Everything works fine. I can stop & restart the controller just fine. Now, I’m ready to log off, so I manually stop the controller, and log the user off & I’m back to the login screen.

At the login screen, I notice that the modem is no longer “ready to receive” and it doesn’t receive faxes. Prior to using the controller, the modem was always in a “ready” state at the login screen.

So I log the user back on, but when I try to start the controller, Message Manager tries to load the controller – and then it locks up. I have to kill Winfax with the task manager. Winfax will not run again without a reboot.

I can be logged off & receive faxes – providing that I did not start the controller at all while I was logged on. And if I do run the controller & log off, I can no longer receive while I’m logged off, plus I can’t restart the controller without rebooting.

I tried other modems. I tried using Com 1 instead of TAPI. (Under Win 2000 Pro, the Telephony service has nothing to configure.) I tried different init strings for the modems, specifically a reset init string. I re-created all the log/status files.

Prior to the reinstall, I had the controller load via startup instead of manually. My guess is the Winfax service always did work while I was logged off, but I couldn’t receive because the controller had been run first.

Seems like its something with how the controller releases and/or resets the modem when the controller is closed??? Doesn’t seem to be TAPI as I have the same problem bypassing TAPI. Are there some registry entries worth checking or changing?

I’ve got a lot invested in this problem. I’m not ready to give up quite yet. Any help would be greatly appreciated.

Gary Reid