Fax Software

Community Forums

#6808

Anonymous
Member

@gary wrote:

Thank you for your quick response.

“Sending & receiving…when logged off” is checked, and does work – provided that I have not run the controller at all when I do log on.

I make a point of logging in as the same admin user every time (the same user that installed Winfax to begin with). I have not tried it under a different user.

If I boot the machine, when the login screen comes up, I can receive faxes before I log in, which indicates that the Winfax service is working. Likewise, if I log in & log out – without starting the controller while logged in – it receives when I log back out, which again, indicates that the Winfax service is working.

But if I log in, start the controller, and log out, the Winfax service does not work when I log back out. It doesn’t matter if I close the controller manually or let the OS close it. Then, if I immediately log back in, the controller won’t load. I see it in the taskbar (auto receive disabled). If I right click on it, I get nothing, so I start Message Manager and it locks up at the point where it initializes the controller. The system doesn’t hang, just Winfax. Once I kill Winfax, the system still works and I can even use the same modem to connect to the internet, etc. The only way to get Winfax to work again is a reboot.

From what I understand, the controller has control when logged on. The service has control when logged off. Seems to be an issue with how the controller closes & releases the modem, so the service can take over when you log off.

How the modem fits into this changeover, I have no idea. Because of the status lights on my modem, I do know that you can see the service initialize the modem when you first boot up. When you start the controller, the status lights don’t even flicker. They remain in the “ready” mode, which is all good. When you close the controller, the status lights indicate a “not ready to receive” state, which you would expect. Then, when you log off & the service takes control, you would expect the modem to be “ready” again, but it isn’t. It stays in the “not ready” state.

It there a way to audit any of this or create a log? Does Winfax create it’s own log?

Could this be a DCOM issue? A security issue? Anything to check here?

I really appreciate your time on this. Symantec support was no help at all.

Gary Reid

When you log back on, (before starting the Controller) what applications are active in your task manager?

then start the controller and check the tasks again. Then close the controller, and check the tasks. Do you have a left over occurance of “WinFax MOD ” or wfxmod32″ running?
or multiple copies of it?

There is also a debug mode you can enable to see what the modem is doing.

To enable Debug Mode

Exit all open programs and stop the WinFax PRO service
Click Start, point to Find, and click Files or Folders. The Find dialog box appears.
From the Look In drop-down list, select the drive on which you installed WinFax PRO/TalkWorks PRO.
Check Include subfolders (if not already checked.)
In the Named field, type:

symdiag.exe

and click Find Now. Windows displays all files matching the search criteria.
Double-click the found file. You will receive notification that this should only be used with the direct assistance of a technician and to proceed with caution.
Click OK, click Enable/Disable features. Select Debug Mode (Currently Disabled,) and click Enable. The display will change to Debug Mode (Currently Enabled.)
Click Close, and click Close again. You will be asked if you would like to launch the Message Manager. Click Yes.

NOTE: When you launch the Controller with Debug mode enabled, you will receive a Fax/Modem alert indicating that the debug mode is enabled. The name of the log file is called .log and is located in the Data directory.

To disable Debug Mode

Exit all open programs and stop the WinFax PRO serviceClick Start, point to Find, and click Files or Folders. The Find dialog box appears.
From the Look In drop-down list, select the drive on which you installed WinFax PRO/TalkWorks PRO.
Check Include subfolders (if not already checked.)
In the Named field, type:

symdiag.exe

and click Find Now. Windows displays all files matching the search criteria.
Double-click the found file. You will receive notification that this should only be used with the direct assistance of a technician and to proceed with Caution.
Click OK, click Enable/Disable features. Select Debug Mode (Currently Enabled), and click Disable. The display will change to Debug Mode (Currently Disabled.)
Click Close, and click Close again. You will be asked if you would like to launch the Message Manager. Click Yes.