Fax Software

Community Forums

#7211

transition
Member

😀

Well thanks to you folks and another tip I found online, I got my WinFax Pro Sharing to Work on Windows XP Machines with SP2. See my previous post “At the point of tears” for more details. This has taken me about 30 hours to figure out (yes, we tracked our time). I hope this will alleviate the pain the rest of you may be experiencing.

Here is how I got it to work step by step. I just did it and came on here to share it all with you while it is still fresh in my mind:

HOST COMPUTER
1. Took the advice of moderator and decided to just try and get 10.03 working first. Unistalled 10.04 on the host, deleted anonymous login from Component Services- Dcom, deleted all WinFax exceptions from Windows firewall. Rebooted and installed 10.03. You then have to reboot. Please note, I did not install host sharing at this point, just the modem on my file server.

2. Took the Symantec instructions “Fax Sharing client cannot connect to host after Installing Windows XP SP2” and followed them to a T, rebooting along the way as instructed. However, I did take the additional step of add the WFXPING.EXE to my exceptions as well at that time.

3. I then found on another site the following EXTRA steps.

Step 5: Final Instructions
All the instructions above should be applied to all computers. It may not be necessary to apply them to all computers, but it is thorough. Make sure that all computers are on the same workgroup and that all computers have file sharing enabled. I would share at least one folder on each computer to verify that file sharing is enabled. Check that you can see the shared folders on all the comptuers. To check go to Start Menu > Run > Type “\PcName” where PcName is the name of the computer you want to view. If a window pops up with a list of shares on that computer then file sharing is properly enabled. You may also need to create a user on the host computer for each client. The new user must match the username and password of the client’s currently logged in username and password. The users created must have administrator rights. Be sure to restart all computers have making these changes.

If you have trouble after following my steps please see below:

Optional Final Step: More DCOM Config
This step may also be needed to get winfax working.
Start Menu > Run > Type “dcomcnfg”
From the Console Root, open Component Services > Computers > My Computer.
Right-click My Computer, and click Properties.
In the My Computer Properties dialog box, on the “Default Properties ” tab, make sure the box “Enable Distributed COM on this computer” is checked. Then set the “Default Authentication Level” box to “None” and the “Default Impersonation Level” to “Anonymous”. Then click ok and restart. You may have to do this on all computers.

Registry Tweak That May Be Required
Cut and paste the following (between the lines) into notepad and save as something like RPC_ON.REG. Double click to activate file:


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\RPC] “EnableAuthEpResolution”=dword:00000001
“RestrictRemoteClients”=dword:00000000

To Reverse the RPC changes later, if needed, use the following in a registry file called RPC_OFF.REG


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\RPC] “EnableAuthEpResolution”=dword:00000000
“RestrictRemoteClients”=dword:00000001

Re-boot the computer and good luck!

I did check to see that I could see the client computer from the host. I did the “Optional Final Step” at the host and rebooted. I did not do the registry tweaks.

4. After all of this was done, I then enabled Host Sharing on my Host computer.

CLIENT WORKSTATION

1. Unistalled 10.04, deleted the anonymous logon, deleted the Winfax exceptions from Firewall. Rebooted.

2. Installed 10.03 and when it asked me to set up, I bypassed setting up the “Client Sharing” option. Rebooted.

3. Took the Symantec instructions “Fax Sharing client cannot connect to host after Installing Windows XP SP2” and followed them to a T, rebooting along the way as instructed. I just did steps 1-4 and then 7 because I was at a Client computer. Rebooted.

4. Did the extra step at the Client computer as outlined below:

Optional Final Step: More DCOM Config
This step may also be needed to get winfax working.
Start Menu > Run > Type “dcomcnfg”
From the Console Root, open Component Services > Computers > My Computer.
Right-click My Computer, and click Properties.
In the My Computer Properties dialog box, on the “Default Properties ” tab, make sure the box “Enable Distributed COM on this computer” is checked. Then set the “Default Authentication Level” box to “None” and the “Default Impersonation Level” to “Anonymous”. Then click ok and restart.

5. After rebooting, I went to enable Client sharing and got the dreaded error “Access Denied – Check that this is the correct host name” Not disheartened, I went to step #6.

6. Implemented John Nadeau’s fix on this forum. Specifically, I went back to the host and clicked allow on all 4 entries

“… Local Launch, Remote Launch, Local Activation, Remote Activation (whereas Symantec said to only select Remote Activation)”

in Component Services – My Computer – DCOM Config – Winfax Attachment.

7. Went back to the Client computer and tried to set up Client Sharing and low and behold, it connected, it let me finish setting up the client workstation and we could now see faxes on the Host.

I would welcome any comments on whether this “extra step” now makes my computer a higher security risk.

Final notes

– I am not going to upgrade to 10.04. If it ain’t broke, don’t fix it.
– I didn’t open any ports on the host and deleted the open port I had before (1090)
– didn’t check that my oleaut32.dll was the same (was using a different client this time)

I hope this helps you all.