Fax Software

Community Forums

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #2738

    I have tried several attempts to make this work and keep running into problems. I tried DDE code (Helen Feddema) that would insert information from my table into the cover page but could not get it to included a filtered attachment.

    I have tried using vba code (below) which would include the filtered attachment but the cover page data (fax number, to, company name) would not fill in.

    Any help would be GREATLY appreciated!

    Dim objFaxSend As wfxctl32.CSDKSend
    Dim QuoteID As Long

    Set objFaxSend = New wfxctl32.CSDKSend

    With objFaxSend
    .SetCompany (Me.Customer)
    .SetTo (Me.contactname)
    .SetSubject “The Subject”
    .SetNumber (Me.CustomerFax)
    QuoteID = .Send(1)
    End With

    Set objFaxSend = Nothing


    I don’t see any cover page being added in your code. You need to specify some sort of cover page text before a cover page will be used
    also don’t see any code adding the attachment, or printing to the WinFax printer driver?


    I have changed this code many times. I still can’t get it to work.

    Here is my latest:

    Dim objWinfaxSend As Object
    Set objWinfaxSend = CreateObject(“WinFax.SDKSend8.0”)
    objWinfaxSend.SetClientID (Me.Customer)
    objWinfaxSend.SetCoverText (“QUOTE”)
    objWinfaxSend.SetNumber (Me.CustomerFax)
    objWinfaxSend.SetTo (Me.contactname)
    objWinfaxSend.SetCompany (Me.Customer)

    objWinfaxSend.Send (1)
    objWinfaxSend.SetPrintFromApp (1)
    objWinfaxSend.ShowSendScreen (0)
    DoCmd.OpenReport “RPT_QuoteDetailsTotalWF”, , , “[quoteid] = Forms!frmQuoteInformation![QuoteID]”

    I see the report print (flash on screen) but the report never makes it to WinFax. The cover page populates but I am missing the filtered report.

    Any help would be GREATLY appreciated.

    Access 2003, WinFax Pro 10.04, Windows XP

    Thank you in advance.


    WinFax PRO 10.02 and Windows XP? Not compatible with SDK and this may be the problem. Make sure you have version 10.03, and then only can you update to 10.04. (You can’t update 10.02 to 10.04)


    Thank you for your reply. I had 10.03 and was having issues. I saw a posting to upgrade to 10.04. I found the patch and updated my 10.03 version.

    I am open for other suggestions. Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.