Fax Software

Community Forums

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #4126
    dr.rocket
    Member

    In keeping with my motto of, “If it ain’t broke it’s because I haven’t fixed it yet,” I upgraded from a functional version 10.0 to a functional 10.01, and then to a not-totally functional 10.03.

    I’m running Win XP SP3 and using a Pactical Peripherals PM14400 FXSA external modem conected to a PCI serial card. According to Device Manager, the only available COM ports are 3,4,5, but COM 3 is the only port on which the modem is discoverable for quarrying.

    Historically, COM3, TAPI, and Class1 were settings that worked successfully; but, now with the same settings, incoming faxes are dropped during the “Answering” phase, despite being set to answer after at least 2 rings. With the modem set to Class 2, the fax is received, but trying to access the Receive Log results in “WinFax PRO has encountered a problem and needs to close.” Actually, I now get that same error message when trying to access the Receive Log whether in Class 1 or Class 2, but faxes are only received in Class 2.

    I don’t know what about installing 10.03 (which is supposed to be the latest and greatest version) has caused the COM 3, TAPI, Class 1 combination to no longer work as it did. I would like to get 10.03 to work properly, rather than downgrade back to 10.01 (which, at this point, might exhibit the same issues), but I’m at a loss as to what to try next.

    I hope, perhaps with WinFax Tools, a simple fix exists. Please advise.

    #9300
    dr.rocket
    Member

    Addendum: The error message I receive when trying to access the new received messages via right-clicking the system tray icon is:
    A General Protection Fault has occurred….

    WinFaxPRO Viewer – 1401001.fxr:wfxctl32.exe – Application Error
    The instruction at “0x1010f703” referenced memory at “0x049c0b80.” The memory could not be “read.”

    The only changes I get when trying to access a different new received message is the *.fxr number, and the referenced memory location.

    Does this information help with a diagnosis and a course of corrective action?

    #9301
    admin
    Keymaster

    what type of phone line are you using? are you using a VoIP type line? or an analog telephone line?

    under Advanced (in Receive) make sure all options are turned off (Remote fax Retreival, Call Discrimination and Distinctive Ring is set to off)
    Set to answer to 2 or more rings.
    Set initialization string to : AT&F&D2&C1&K3S7=55
    Set Flow Control to : AT&K3
    Use Hardware Flow Control : Checked/Enabled
    Turn off 2D Compression and ECM for sending/receiving

    if that doesn’t help, reconfigure the modem. Tools, Program Setup, Select Modems & Communications Devices.
    hold down SHIFT key, select the Fax Modem from the list, click PROPERTIES. Click Yes to configure the Fax Modem.

    #9302
    dr.rocket
    Member

    I’m using a dedicated POTS line.

    With the exception of turning off the 2D Compression, those are the exact settings I already have. It didn’t help. Does it matter which “location” is chosen for the active device, e.g., Default vs. Dial as entered. Those are the only choices currently available from the drop down menu.

    As for the SHIFT key technique, I must be doing something wrong because I’m not being given the option to configure the Fax Modem; but I have previously removed and added the modem multiple times, to no avail.

    What next?

    #9303
    dr.rocket
    Member

    I was finally able to reset the modem with the shift procedure, but the only change that has been observed in Class 1 is receiving a fax made it past Answering, but then stuck at Connecting without proceeding. Set to Class 2, the fax was received, but I still can’t access the new messages in the Receive Log without a fault shutting down the whole program. Also, despite being set to anwser after 2 rings, it seems like the modem is answering after 1 ring.

    I’m surprised that the upgrade to 10.03 has been so troublesome. Since it was supposed to be compatible with Win XP I was hoping for an easy upgrade. What do you suggest I try next?

    Thanks in advance.

    #9304
    admin
    Keymaster

    Is the modem detected and listed as a Practical Peripherals PM14400 FXSA in Windows? This is an older modem, and I am not even sure if it is TAPI / Windows compatible. In WinFax, You may need to set it as COM3 port instead of TAPI (In WinFax, Tools, Program Setup, Modems & Communications, Select the modem , then click Properties)

    #9305
    dr.rocket
    Member

    The modem is listed as a Standard 14400 modem. My previous settings (for 10.0 and 10.01) had the modem on COM3 and set as TAPI. I have also tried it set as COM3, but that was worse than having it set as TAPI. The modem was working successfully in Win XP with the earlier versions of WinFax PRO (10.0 and 10.01); I don’t know what changed with 10.03 that it is now acting so persnickety.

    #9306
    dr.rocket
    Member

    Is there any harm in leaving the modem set as Class 2 TAPI (rather than Class 1)? Test faxes are successfully received with those settings. BUT, what can I do about the General Protection Fault I now get when trying to access anything in the Receive log? Could SymDiag help?

    #9307
    admin
    Keymaster

    Can you view these faxes that are received ? The General Protection fault can occur if there is corruption in the fax image file. While it may appear you’re receiving the fax, you might just be receiving garbage data that fails when you attempt to view it.

    You can try clicking “Set Default Fax View ” in WinFax Tools. This will set WinFax to show information only, so it will not automatically display a fax image when you switch to the receive log in WinFax. If the error occurs when trying to open the fax image, then its probably a bad fax.

    Windows XP should detect the modem as a Practical Peripheral model, if it doesn’t, then its possible this modem isn’t fully TAPI compatible or fully compatible with Windows XP. Using “Standard 14,400 bps modem” uses the Generic Settings in Windows.

    #9308
    dr.rocket
    Member

    Sadly, my trusty Practical Peripherals 14400 FXSA modem may be the source of the issues I’ve been having with version 10.03, although it worked fine for versions 10.0 and 10.1. I took the Practical Peripherals modem out of the equation, and recruited my old Courier V.Everything, which was recognized by Win XP (the PP modem wasn’t) and was set up in WinFax as a TAPI modem using Class 1. The USR modem sent and received faxes without a problem.

    I think you were also right about the WinFax program experiencing a General Protection Fault related to the [bad] faxes received by the PP modem when it was in Class 2. The question now is, how do I delete the bad faxes? When I try to delete them within WinFax, WinFax crashes. I guess I’m going to have to hunt them down via Windows Explorer and delete them there. I have the date and time of the corrupt received-faxes, but I don’t know what directory they’re in and what their associated file names would be in order to find them for deletion. If you agree that that is how I will need to proceed, would you please give me a roadmap to find those files.

    If you have an easier method for deleting those bad faxes, I eagerly await for your instructions.

    Thanks for all your help.

    #9309
    admin
    Keymaster

    The ideal method to delete those bad faxes would be to do so within WinFax itself, if you can prevent from viewing the fax. If you attempt to view the fax, or view the thumbnail preview of a bad fax, WinFax will crash.
    To prevent the thumbnail preview, you need to “Set Default Fax View ” in WinFax Tools. This will set WinFax to show information only, so it will not automatically display a fax image when you switch to the receive log in WinFax. If you can get into the receive log after doing this, you can then select the known faxes that are bad and delete them.

    If that does not work, then you would need to go to the data folder where your WinFax data is located. You can find where your data is located by using WinFax Tools and clicking “WinFax Info”. This will display the Data folder path (examples are: c:winfaxdata or c:program fileswinfaxdata)
    then, look for files with a .fxr extension. The fxr designates received fax files. Each page has its own .fxr file, so a 2 page received fax may have filenames like 2934001.fxr, 2934002.fxr. The last 3 digits represents the page number. The first 4 digits is a number generated by WinFax (it does not represent the time or date). You can also look at the date and time of these fxr fax files to determine if these are the bad faxes.
    If you delete these fxr fax files, they will still appear in your logs but will show empty data when you try to view them (this will prevent WinFax from crashing) . you can then successfully delete the log entries from your receive log.

    #9310
    dr.rocket
    Member

    Even with “Set Default Fax View,” WinFax would crash due to those bad faxes, so I had to resort to your alternative method. I am happy to report that I am now free of those bad faxes and can access the Receive Log without WinFax crashing.

    I want to thank you for all your help and your informative, detailed instructions as to how to fix the problem. It has been a learning experience and is much appreciated.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.