Fax Software

Community Forums

This topic contains 1 reply, has 0 voices, and was last updated by  admin 7 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4137

    pp-ablehit
    Member

    I finally got things up and running in a mixed client setup (XP, 2000)

    Here is how I got things talking:

    Winfax 10.03 Host Installation on XP SP3 Patches up to February 10, 2012
    SERVER
    Disable ALL antivirus and firewalls (Get client/server up and running without interference)
    Install Winfax as a user with administrator privileges
    Setup you modems as per the modem wizard
    Reboot after setting up Winfax
    Login as a user with administrator privileges
    Start Winfax Manager
    Select – TOOLS – PROGRAM SETUP –FAX SHARING HOST
    Check – Use this Winfax PRO station as a fax sharing host
    DO NOT USE A PASSORD!
    Save your settings
    NOTE: IF YOU EVER CHANGE YOUR HOST SETTINGS (EVEN IF YOU CLICK OK AND CHANGED NOTHING) OR LOGIN USING A DIFFERENT ACCOUNT ON THE WINFAX HOST SERVER/WORKSTATION YOU MUST REPEAT EVERYTHING BELOW, MAKE SURE YOU DELETE THE ANONYMOUS LOGON ACCOUNT WITHIN THE PROPERTIES (NOT THE ACTUAL USER ACCOUNT) AND RE-CREATE IT !! VERY IMPORTANT !!:
    DCOM Settings ON SERVER/HOST/WORKSTATION (XP SP2,3):
    Click START – RUN – dcomcnfg – OK
    Click COMPONENT SERVICES – COMPUTERS
    Right Click – MY COMPUTER – PROPERTIES
    Click on the COM SECURITY TAB
    On Access Permissions – EDIT LIMITS – Add a User Called ANONYMOUS LOGON
    Check Local Access and Remote Access
    If the ANONYMOUS LOGON account was already there, delete it and re-create it.
    IF THIS IS A WORKSTATION/CLIENT – YOU ARE DONE – REBOOT – YOU MUST REBOOT!

    HOST/SERVER ONLY
    Under Launch and Activation Permissions, Click on EDIT LIMITS
    Add a User Called ANONYMOUS LOGON
    Check Remote Access
    If the ANONYMOUS LOGON account was already there, delete it and re-create it.

    Click COMPONENT SERVICES – COMPUTERS – MY COMPUTER – DCOM CONFIG
    A WARNING MAY POPUP, JUST CLICK YES
    LOCATE THE Winfax.attachment Icon

    RIGHT CLICK – PROPERTIES

    Click the SECURITY TAB
    Under Launch and Activation Permissions Select CUSTOM – EDIT
    Add the ANONYMOUS LOGON account and Check REMOTE ACCESS
    If the ANONYMOUS LOGON account was already there, delete it and re-create it.
    Save your settings

    REBOOT THE HOST SERVER, YOU MUST REBOOT!!!

    NOTE: IF YOU EVER CHANGE YOUR HOST SETTINGS (EVEN IF YOU CLICK OK AND CHANGED NOTHING) OR LOGIN USING A DIFFERENT ACCOUNT ON THE WINFAX HOST SERVER/WORKSTATION YOU MUST REPEAT EVERYTHING ABOVE RELATED TOO DCOM, MAKE SURE YOU DELETE THE ANONYMOUS LOGON ACCOUNT WITHIN THE PROPERTIES (NOT THE ACTUAL USER ACCOUNT) AND RE-CREATE IT !! VERY IMPORTANT !!

    #9386

    admin
    Keymaster

    Welcome to the forums and thank you for posting the steps.

    some additional comments;

    1. generally, you don’t have to reboot after performing the DCOM steps – once you are sure the connection works you can reboot the Host, wait until it starts up with WinFax Controller active, then reboot the clients and check if they still connect.

    2. you can view your Host Settings in WinFax setup, but always click “Cancel” , never “OK”. If you change any setting in this dialog, such as adding/changing password, and click “OK” you will need to repeat these steps on the HOST ONLY: Host settings are on the Host only, so changes to clients are not required.
    – delete existing “Anonymous Login”
    – add “Anonymous Login”
    – add “WinFax.Attachments” DCOM security settings.

    3. mixed Host/Client versions don’t work, example if you have a 10.03 host and 10.0/10.01/10.02 clients, they will not connect. The exception is 10.04 clients, these you can connect to a 10.03 host.

    4. The event viewer is a good troubleshooting source to determine if you have a DCOM security issue. If you had a working host/client connection and it suddenly stopped connecting, check the event viewer to see if there are any DCOM related errors when you attempt to connect to a Host. If so, you probably have re-do the DCOM security settings on the HOST only.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.