Fax Software

Community Forums

This topic contains 9 replies, has 0 voices, and was last updated by  admin 10 years, 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3924

    BillC.
    Member

    I have a P4 2.6MHz computer running with Windows XP Professional, service pack 3. I have installed a Smartlink 56K modem(voice, fax and data) on Com3. It is a Class 1 internal modem using TAPI PORT mode. I have installed the english version of WinFax Pro Version 10.04 software. I have not received any error messages either during installation or operation.

    However, while I am able to send faxes including faxes by email, I am not able to receive any. I have carried out the hyper terminal test on the modem and all comes out positive. I installed the Windows Fax Console and tested the modem for fax sending and receiving. That software worked perfectly. I have unistalled both the Winfax software and the modem and then reinstalled each checking the Winfax settings several times and can see nothing unusual or problematic. I am at a complete loss as to why the software is not receiving fax as it should.

    Any help with this problem is most welcome

    Bill C.

    #8521

    admin
    Keymaster

    Do you have any other devices (such as fax machines) connected on the same phone line? If so, disconnect them and try receiving a fax.

    Also, when a fax is received, do you see the status dialog appear “Answering” the call?

    Is there any error or failed event entry in the Receive Log? Usually this will be displayed with a red “X” and it will indicate an error message in the Information area.

    In the WinFax receive setup, How many Rings do you have set to answer the call? If you have this set to 1, set it to 2 or more rings.

    Also, version 10.04 is an update patch for version 10.03 users that are using Fax Sharing. If you upgraded to 10.04, you need to ensure your previous version was 10.03. (The update will cause problems on installs of 10.0, 10.01, or 10.02)

    #8522

    BillC.
    Member

    No, other than the telephone, there is nothing else attached to the telephone line.

    Yes, the Status dialog box comes on the screen and the word “Answering” appears within the dialog box. I get an intermittent “beep” sound but nothing comes through.

    No, no entry appears in the Received Log at all.

    I have tried the number of rings set to answer a call at three and four. Neither make a difference.

    The update patch 10.04 updates version 10.03.

    Any additional suggestion/things I could try are most welcome.

    #8523

    admin
    Keymaster

    You can try these suggestions:
    http://service1.symantec.com/SUPPORT….w=docid

    if you are attempting to receive from the same fax machine, I would also suggest trying to have another machine (or computer) send you a fax.

    #8524

    BillC.
    Member

    I have tried to receive faxes from three different fax machines all with the same unsuccessful results. I will however review the suggestions at the website offered.

    Below I have included several lines extracted from the modem log showing attempts to receive a fax. Hopefully someone with more technical knowledge might be able to offer/explain what the lines mean(eg. What is TSP??)

    02-07-2009 13:42:20.731 – Passthrough On
    02-07-2009 13:42:20.731 – TSP Completing Async Operation(0x00010088) Status 0x00000000
    02-07-2009 13:42:20.731 – TSP(0000): LINEEVENT: LINECALLSTATE_CONNECTED
    02-07-2009 13:42:54.512 – TSP(0000): Dropping Call
    02-07-2009 13:42:54.512 – Passthrough Off
    02-07-2009 13:42:54.512 – Session Statistics:
    02-07-2009 13:42:54.512 – Reads : 161 bytes
    02-07-2009 13:42:54.512 – Writes: 117 bytes

    02-07-2009 13:59:19.778 – Interpreted response: Ring
    02-07-2009 13:59:19.778 – TSP(0000): LINEEVENT: LINE_NEWCALL
    02-07-2009 13:59:19.778 – TSP(0000): LINEEVENT: LINECALLSTATE_OFFERING
    02-07-2009 13:59:19.778 – TSP(0000): LINEEVENT: LINEDEVSTATE_RINGING(0x1)
    02-07-2009 13:59:25.778 – Recv: RING
    02-07-2009 13:59:25.778 – Interpreted response: Ring
    02-07-2009 13:59:25.778 – TSP(0000): LINEEVENT: LINEDEVSTATE_RINGING(0x1)
    02-07-2009 13:59:30.043 – TSP(0000): Accepting Call
    02-07-2009 13:59:30.043 – TSP(0000): LINEEVENT: LINECALLSTATE_ACCEPTED
    02-07-2009 13:59:30.043 – TSP(0000): Entering Passthrough Mode
    02-07-2009 13:59:30.043 – Passthrough On
    02-07-2009 13:59:30.043 – TSP Completing Async Operation(0x00010323) Status 0x00000000
    02-07-2009 13:59:30.043 – TSP(0000): LINEEVENT: LINECALLSTATE_CONNECTED
    02-07-2009 13:59:39.168 – TSP(0000): Dropping Call
    02-07-2009 13:59:39.168 – Passthrough Off

    As you can see, the call comes in, the passthrough is on, the call is connected and then the call is dropped resulting in nothing being received.

    Any suggestions/ideas are welcome.

    #8525

    JohnD
    Participant

    there should be much more to the log, with info on the initialization of the fax modem. TSP is the telephony service provider, in this case, the universal modem driver (unimodem).
    The log doesn’t indicate and specific WinFax errors, since it is a TAPI Modem log only. The log does indicate that the fax modem is detecting the call, and answering it but doesn’t tell me whats happening in WinFax. It appears it may be modem driver or software related,
    I’d suggest updating the Smartlink fax modem drivers for the latest ones for Windows XP , or replacing it with another type of fax modem.

    There is a WinFax specific debug mode that can log all modem data with WinFax — http://service1.symantec.com/SUPPORT….3134404

    #8526

    BillC.
    Member

    Thanks for your reply.

    The log supplied in Post number 5 is only a portion of the full log which I thought would be too long to post. I can post the log if it would be helpful to diagnose the problem.

    The drivers for the modem are the most up to date available for Windows XP. I have not tried replacing the modem. As stated in post number 1, I loaded the Fax Console from Windows and tried it with the modem. I was able to send and receive faxes without any problems. I assumed then that the modem was working properly and the problem seemed to be with Winfax.

    I accessed the debug mode found in the URL you provided and ran the “Symdiag.exe” file. It produced 15 pages of data much of which seems to be repetitive. However I am not a software technician and if there was a problem in the data listed I would not be able to recognize it. Is there anything in particular I should look for in the data listing that I could post?

    Although my modem worked with the Windows Fax Console should I try another anyway? Any particular brand name you could suggest that might work?

    I appreciate any additional help you can provide.

    #8527

    admin
    Keymaster

    since it works fine for both sending and receiving in Windows XP Fax console, its likely a specific problem with WinFax and the Smartlink modem.

    You could try switching the Port settings in WinFax from TAPI to COMx (where x is the comport of the modem , in most cases this would be COM3)
    When using COM port mode, WinFax communicates with the fax modem directly instead of using the Windows TAPI layer.

    another option
    You need to change the modems initialization string sequence.

    In Program Setup, double-click Modems and Communications Devices.
    Select the modem, and click Properties.
    Click the Fax tab.
    Change the Initialization string sequence in Line 1 to AT&F1
    Remove all data from Line 2 through 4, as well as the Flow control line.
    Uncheck “Use hardware flow control”.
    Click OK, click OK again, and click Close.

    Here are some other suggestions:
    http://service1.symantec.com/SUPPORT….9015304

    For the log you want to post the portions where WinFax answers the call, and you can see commands where it is attempting to receive the fax.

    #8528

    BillC.
    Member

    Again Thanks.

    In partial response to your message, my modem is connected to com3.

    Under Program Setup, Modem and Communications Devices, I highlited my modem and clicked Properties. The Common Port option identifies either Tapi or Com1. There is no listing for com3. Is Tapi and com3 one and the same?

    When I highlite the modem and click on Test Com Ports, the dialogue identifies com1 and the message states “No Modem found on this Port”. The system searched further and finds the modem under com3.

    If Tapi and com3 are not one and the same how do I change the port from Tapi to Com3 even though Program Setup finds the modem in com3?

    #8529

    admin
    Keymaster

    Under Program Setup, Modem and Communications Devices, select the modem, hold the SHIFT key, then click PROPERTIES. WinFax will report the modem is not configured, re-configure it by going through the Wizard setup again. Probably the first time the wizard was run (during the install) it did not find anything on COM3, so it was not added as a port, this is common on software based fax modems)

    no, TAPI and COM3 are not the same. Once you reconfigure the modem ,check back in the drop -down list and confirm you have both TAPI (default) and COM3 available as selections. (COM1 may still be listed, but no modem is found there)

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.