Fax Software

Community Forums

This topic contains 1 reply, has 0 voices, and was last updated by  admin 6 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4179

    pp-stallwade
    Member

    Have used Winfax for years for a custom application written in Visual FoxPro 6 and taking advantage of Winfax SDK code. We also utilize a third-party printing utility that can print in the background–Flextext from a company called Enterprises Solutions–no longer in business that I can find. Presently Winfax 10.02 is functioning fine on a Windows98SE machine, but this machine is now failing. We have another problem in that Windows98 cannot join a MS Server 2003 or 2008 domain–security issues. Backdoored that issue by logging into a Windows 2000 server and some workarounds.

    I am now trying to upgrade the Win98SE machine to Windows XP, hoping I can do away with the Windows2000 server as well. I have tried in the past–but have had issues with Win XP server packs. So I did a fresh install of Win XP with Service Pack 1 only. I have installed Winfax pro version 9, 10., 10.02 and 10.04. Same problem with all versions – from the Message Manager- “Automatic Printing of the file has failed. You will need to activate the printing manually.”

    I think the issue is Winfax-WinXP related somehow. Just now sure where. I’ve been reading other forums here and see there may be a timing/timeout issue in that maybe not enough time is given to create the attachment? It also appears to hang while creating the attachment if I do not manually start the printing. Obviously, I do not want to manually start each fax if I can avoid it.

    Any suggestions would be much appreciated. Thanks.

    #9545

    admin
    Keymaster

    Version 10.02 will not work with SDK and printing attachments when using Windows XP due to a bug in the SDK code. This was fixed in version 10.03 . If you installed 10.0 (or an earlier version of WinFax) it should have worked. So it is possible there is another problem and it could be related to timing of the SDK code. Also, if you installed 10.04 overtop 10.02, this would cause other problems and you’ll need to uninstall and reinstall a proper version.

    I’d suggest trying version 10.03 and remove the older version first. If you have 10.02, you can create a 10.03 image installer. you have to uninstall then reinstall 10.03 (or use the WinFax Clean Tool to remove Winfax first)
    http://www.getfaxing.com/downloads/patches/index.php?file=Patch1002-1003.exe

    You should also try attaching another document (txt or doc for example) and confirm that the WinFax printer drivers are installed.
    If you are using Windows XP 64 bit edition it will not work (the drivers are not 64 bit compatible)
    If the problem only occurs when using your custom code then it may require some code changes.
    Do you have access to the VFP code that uses the WinFax SDK? and can you modify it if required?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.