Fax Software

Community Forums

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2612

    I am currently writing an automated fax program in VB6. I want to use a custom cover page with the company logo. Send works fine if I use a Quick Cover Page, but when I use the custom page, the Cover Page Filler window opens and I have to click the Send button to continue.

    The fields in the custom cover page which are filled programmatically are:
    Fax Number:
    All of these are already filled out properly when the filler window pops open.

    How can I suppress the opening of the Cover Page Filler window when using a custom cover page?

    This is my code:

    sendEventObj.LeaveRunning ‘leave fax controller running – strongly recommended by documentation

    ‘// dialing settings
    sendEventObj.SetUsePrefix (1) ‘true
    sendEventObj.SetDialPrefix (“9”)

    ‘// recipient settings
    sendEventObj.SetNumber (strFaxNumber)
    sendEventObj.SetTo (strDebtorName)
    sendEventObj.SetDate (Now())
    sendEventObj.AddRecipient ‘this is mandatory

    ‘// cover page settings
    sendEventObj.SetUseCover (1) ‘true
    sendEventObj.SetQuickCover (0) ‘false

    ‘// additional settings
    sendEventObj.EnableBillingCodeKeyWords (1)
    sendEventObj.SetKeywords (strRecordID)
    sendEventObj.ShowSendScreen (0) ‘deliberately NOT show Send Dialog or it will take control and hang program
    sendEventObj.SetPreviewFax (0) ‘stop this dialog too!
    sendEventObj.ShowCallProgress (1) ‘show the call as it progresses

    ‘// attach Word doc (doc will be converted to image automatically)
    sendEventObj.AddAttachmentFile (FILEPATH & TOBESENT & strDocName)

    lblMessage.Caption = “Sending Fax”
    sendEventObj.Send (1) ‘1 = create EventID


    I assume the cover page you are using has a editable text box (an area on the page where you can enter your cover page text)

    if you don’t define any text to be put on the page in your VB code, then WinFax assumes that you want to manually enter some text, so the cover page filler appears and it waits for the user to input some text to go on the cover page.

    You have a few options, I am not sure if the 1st one will work because it has been many years since I’ve tried it myself, but here is what you can try:

    1) edit the cover page in the cover page designer and remove the edit text box from the cover page. Save the new cover page .cvp file.
    This won’t allow you to enter any text on the cover page. All text on the page is fixed, and cannot be changed (unless you use the cover page editor again and make the appropriate changes)

    if that doesn’t work, then

    2) add code to add a single space for the cover page text, that way, WinFax won’t prompt you to enter any text in the cover page. The space won’t show up on the cover page.
    example : sendEventObj.SetCoverText(” “) or sendEventObj.SetCoverText(“whatever you want to display on the cover page goes here”)

    I think the command is .SetCoverText() but I could be wrong check your SDK manual to be sure, I’m just going by memory..

    Edited By JohnD on 1168572386


    I did indeed have an editable text box. When I removed it the filler window stopped opening. Thanks very much!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.