Fax Software

Community Forums

This topic contains 34 replies, has 0 voices, and was last updated by  admin 4 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 35 total)
  • Author
    Posts
  • #4057

    kaboondy
    Member

    I have two independent computers that have Win2K installed (much easier than WinXP for WinFax) and are not connected to the internet – hence safe (relatively).

    Each computer (WinFax) independently receives faxes and (almost on a daily basis), the WinFax program “freezes” and no longer receives calls. When I check – the telephone line is free and one can hear a dial tone when you pick up the telephone to check the line – in other words WinFax is not actually receiving a fax (even though it is reporting that it is) and also will no longer receive a fax. The purpose of indicating 2 computers is that this problem is the same on both computers which operate independently.

    There is a blue arrow (pointing left – receiving) under the WinFax icon in the status bar near the system tray and it will remain “hung” in that condition until the computer is shut down and restarted. This can be a significant nuisance as we are not able to constantly monitor the fax – hence hours can go by with WinFax “hung” in the “receive” state without receiving a fax. The Symantec Message Manager Line Status display (when one selects the display status) remains in the hung state with current page “0” indefinately until the computer is rebooted. Exiting the program does not work as the option is “greyed out”.

    Any help would be appreciated. Thank you. ๐Ÿ˜€

    #8950

    admin
    Keymaster

    was WinFax attempting to answer an incoming fax or voice call when it failed?
    What type of fax modem (model) are you using? and it support voice features?
    Do any of the WinFax PRO processes show “Not Responding” – If you display the Task Manager when in a hung state, with Windows 2000 it should display processes wfxctl32.exe, faxmng32.exe (if WinFax Fax Manager is active) , wfxmod32.exe, and wfxsnt.exe ) wfxsvc.exe may be present if you are using the WinFax Service

    #8951

    kaboondy
    Member

    I am sorry I did not get a notification that somehas answered my question.

    1. Yes, the WinFax is in the middle of trying to answer a call – it always freezes in this state/condition.
    2. I believe it is a USR Fax modem – i can get the model information from the Control Panel and write back to you tomorrow.
    3. I do not believe it supports voice features.
    4. I will review the Task Manager tomorrow as I am sure it will hang again tomorrow and report on the processes.

    ๐Ÿ™‚ Thank you.

    #8952

    admin
    Keymaster

    click WinFax Service Options – disable the WinFax Service and the Windows Fax Service.
    click Logs and Phonebooks, Check send/rec limits in WinFax Tools. Report the Receive Log status
    also in Logs and Phonebooks, Click Call Logging Options. Uncheck both options here (if checked), if unchecked (try checking both). Click Apply, then OK.
    also in Logs and Phonebooks, click Rebuild Logs & Phonebooks, Select the “status.wfb” file and click Open to start the rebuild process.
    Exit from Logs and Phonebooks.
    Click Start Controller button to start WinFax.

    #8953

    kaboondy
    Member

    Thank you for your quick response. Unfortunately I do not have internet access for the Win2K computers in the office – also I believe that it would not be safe to connect those computers to the internet for security reasons (as required by WinFax Tools to confirm activation). Hence I can not use WinFax Tools in my office.

    On the other hand, I reviewed all the steps that you refer to in your post – on my home machine that also has the WinFax installed on it (but has WinXP as the OS).

    1. We normally have the WinFax service turned off (or set to manual) – otherwise I have found this to be nuisance (and unneeded to be active) – I do not believe the Windows Fax is active or even installed.

    2. The send/receive limits – we regularly delete faxes or move them to another location (archived on another machine). In other words, the number of faxes in the receive log is usually no more than 30 at any one time. Hence it is highly unlikely that we would exceed the limit available.

    3. If you can advise how to turn off the call logging options directly within WinFax, that would be helpful.

    4. I believe Rebuid Logs and Phonebooks is also a feature in the Maintainance Utility within WinFax. I can try this directly if this will do the same job as WinFax Tools.

    To answer your original questions:
    A. The Task Manager shows the there are NO applications that show as “Not Responding” in the Applications Tab.
    B. The wfxctl32.exe, faxmng32.exe (if WinFax Fax Manager is active), wfxmod32.exe, and wfxsnt.exe show in the “Processes” Tab of Task Manager BUT there is no information that says “Not responding” wfxsvc.exe is not present as we are NOT using the WinFax Service
    C. Computer A has USR 56K Fax INT PnP modem on Com4 (Driver from 3Com 9/15/1998 version 5.0.2167.1 Microsoft Win2000 Publisher) and Computer B has USR 56K Voice PCI (I did not check the Driver information on the control panel for Computer B)
    D. Each Modem is set to TAPI mode.
    E. One modem if Voice and the other is not – but they BOTH behave the same way and crash (or Freeze) within hours of starting.
    F. The setup for the modems in each (separate) computer is identical and as follows:
    Initialization String AT&F&D2&C1&H1&R2&I0S7=100
    ATS36=0

    Flow Control
    AT&H1&R2&I0 (use Harware Flow control box is checked)

    ECM for sending and receiving is Unchecked
    High Speed Conpression 2D is checked

    Com Port TAPI
    Modem Type Class 1 (although Class 2 is an option but is NOT Selected)

    G. Please note that when WinFax is in the “hung” state, the WinFax Pro Program setup will not open or will also freeze when one selects the “Modem and communications Device” in the properties section. This implies that the Modem is somehow frozen in relation to WinFax.

    The way to get WinFax working is to reboot the computer – not really convenient as it is the server and will diconnect all the terminals who will have to relog on and may corrupt outgoing faxes in their queues. The other way would be end all the process in the Task Manager but this is also not convenient if it has to be done every few hours.

    I would appreciate any further suggestions that you might have to solve this issue. Currently, the only solution we have is to reboot the computer and this is what we are doing – often we do not realise that the WinFax has frozen (for hours) and probably miss many faxes.

    Again, thank you.

    #8954

    admin
    Keymaster

    Are both these computers setup as WinFax Host machines? Do the versions match for each system? And, what version are you using?

    Crashing when you try to open the modem setup indicates some sort of modem issue. You should see if Control Panel in Windows detects and is able to query the modem from within the Modem/Phone options in Control Panel. Those 2 USR modems may be “software” modems. You might want to try replacing them with a different model modem, or make sure you have the updated drivers for them installed for the OS you are using (Windows 2000) You can also try changing the modem com port to 3 if it is available to you. Devices active/conflicts with other com ports can cause WinFax to crash/hang. If you have a screen saver, or power saving features turned on in Windows 2000 you should turn them off.

    #8955

    kaboondy
    Member

    One of the machines is a Host while the other is a stand alone. Both have Win2K as the OS and both have WinFax Pro 10.03 installed.

    I did try to access the modem – from both inside WinFax (WinFax Pro Program Setup) as well as through Control Panel. In both situations the computer simply “hung” and did not respond – when WinFax was in the hung state. On the other hand, there is no problem accessing the modem through either Control Panel or WinFax Pro Program Setup when WinFax is not in a “hung” state.

    I believe these are NOT software modems but are hardware modems and I think the drivers are up to date – but I can try to verify that by calling 3COM for support. I wonder if they have any support for such old hardware at this time. If you have any suggestions on how to achieve this, I would most appreciative.

    I can also try to change to Com3 as I don’t believe there is anything on any of the Com ports. Because the modem has a pin setting on the actual modem board that allows it to be Plug and Play (vs the user defined pins selection on the modem board for COM abd IRQ selection) – I just let the modem and computer decide which Com port and IRQ would be chosed. I have read somewhere that Com3 is recomended.

    I definately have screen saver active (trying to save energy as the computer is on 24 hours a day). The rest of the power settings are set to “never” – for hard drive for example. I will definately turn the screen saver off!!

    I will report to you on the outcomes of the above suggestions. Again, thank you.

    #8956

    admin
    Keymaster

    USR’s web site for support is here:
    http://www.usr.com/en/support/

    You can determine your model # by following these instructions
    http://www.usr.com/en/support/support-101?cat=int56k#findcode
    If these are older models, they might be listed under the Legacy Products / Internal Analog Modems or OEM Modems if the modem was bundled with a computer.

    and from there, you can determine what drivers are required and if they are hardware based/controllerless or software modems.

    If com3 is available, it is preferred to have the modem on com 3 instead of com 4. The IRQ should be automatically selected for you, and it should not conflict with any other device installed in your system. Also, the motherboard bios can also limit specific IRQs for specific PCI slots on the motherboard, so which slot the modem is inserted into can limit the IRQ that will be assigned to it. The most common (manual) assignment for COM3 is IRQ 5 (assuming you don’t use a 2nd Printer Port (LPT2) – that is reserved for IRQ 5).

    #8957

    kaboondy
    Member

    This is very very helpful direction. I will get the information as your suggest for the modem drivers as well as the suggestions in the previous post.

    On both computers, there is nothing externally hooked up other than a monitor and network connection (no printers as we have a network printer). Internally, one of them has a sound card that was added. I will ensure there are no conflicts with Com 3 – I assume I can just change the port in Device Manager – Correct? – please confirm.

    What about TAPI – i just noted that I can actually change the Com port within WinFax – would that be the right place to make the change or should it be on the card itself (it has the pins in the board of the card that allow the user to select the Com and the IRQ) or in Device Manager?

    Thank you.

    #8958

    admin
    Keymaster

    you can change the Com port in the Advanced Port Settings in the Modem Properties.
    I don’t recall the steps in Windows 2000, but they should be similar to Windows XP as outlined here:
    https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/mode_changecomport.mspx?mfr=true

    There are two ways to communicate with a modem in Windows. Using TAPI (using the Windows OS) or directly using COM port mode. You can try changing the TAPI/COM settings in WinFax from TAPI to the specific com port. This doesn’t change the com port where your modem is installed, it just tells WinFax to communicate with the fax modem using the com port directly (do not use the Windows TAPI method). The com port you select must be where your modem is installed or WinFax will display “cannot communicate with modem” error messages.

    #8959

    kaboondy
    Member

    This is very helpful as I did not really know any of this information prior to your explanation. Can you please clarify if there is any benefit to using TAPI instead of directly “speaking” with the modem on COM 1, 2, or 3?

    Does this allows a middleman (ie the Windows OS) to transfer the data – TAPI vs COM? Perhaps this is the reason for my problem – as I spoke with USR technical support just a few minutes ago and they confirmed that the Modems are hardware modems. He also confirmed that all windows OS have the correct drivers for the Modems and will automatically install by OS and that I should set the modem board pins to be Plug and Play (which would allow this to happen).

    There is a lot to try here and I would appreciate clarification on the above and I will report to you tomorrow.

    Thank you.

    #8960

    admin
    Keymaster

    Simply, TAPI mode allows you to share the modem with other communication programs. This feature is of no use if WinFax is the only communication program that uses the fax modem on the computer. So for most purposes, you’ll see no difference between choosing TAPI or COM port mode. You can try selecting the actual COM port where the modem is installed instead of TAPI to see if the problem is avoided.

    #8961

    kaboondy
    Member

    Thank you – I will report to you.

    #8962

    kaboondy
    Member

    I can now report some findings to the forum. Just for the other users, I will attach screen shots. When WinFax Freezes, it will no longer receive faxes and the following is seen when I right click on the controller and select “Display Status”.

    [attachment=2:2nqsrfgx]Symantec Message Manager Line Status.jpg[/attachment:2nqsrfgx]

    When we try to close the program to restart, it will not respond. When we try to shut down the computer, there is an error as below:

    [attachment=1:2nqsrfgx]End Program.JPG[/attachment:2nqsrfgx]

    When WinFax crashes, Task Manager shows the following information when WinFax is in the crashed state:

    [attachment=0:2nqsrfgx]Task Manager.JPG[/attachment:2nqsrfgx]

    Under these conditions, when one tries to open WinFax Pro Program setup in order to look up the Properties of the modem – the computer hangs. Also when opening Device Manager and trying to look at the modem properties – the computer also hangs and does not respond.

    Once the computer is rebooted, WinFax works (until it crashes a few hours later).

    Steps taken Computer 1 (based on advice received from the Moderator)
    1. Turned off the screen saver โ€“ monitor was set at Turn off (Never) โ€“ not sure if this matters. The screen saver was always on BUT the screen was never turned off. This did not completely work โ€“ but WinFax did not crash for almost the entire day โ€“ vs a hung state after a few hours.
    2. Change the Modem to Com3 (from whatever it was on already) – the modem was already installed on Com3
    3. Change from TAPI โ€“ to COM3 – This change was made 3 days ago. Since then the WinFax program has not crashed!! :mrgreen: ๐Ÿ˜† ๐Ÿ˜€

    This is a really big deal for us as WinFax was crashing regularly every few hours requiring the computer to be rebooted with loss of efficiency and productivity (not to mention the frustrations). We will continue to monitor this change and report if this was a longer term solution to our problem. We can certainly handle WinFax Crashing every few days (better than every few hours) but would prefer that it not crash at all.

    I have one additional question. In reviewing every single setting of the modem in the control panel, I came across this set of options: Can you please explain what these settings are for and would they be of any help if my issue ultimately is not completely solved. Finally, is it worhwhile to change the settings (for any other reason) or is it best to leave at the default settings. Please see the screen shot below:

    I was not able to attach another screen shot (as 3 is the max). Under the advanced properties, there is an option to “Disconnect a call if idle for more than xx mins. and Cancel a call if not connected within xx secs. The disconnect box is unchecked (hence not selected) but the second option of cancel a call is filled in at 60 seconds – perhaps the call gets cancelled but we should also disconnect – maybe this causes the hangup as well?? Also, I have encountered receipients that have a much longer connect time of almost 1.5 minutes – and had to change the modem initialization string to end in 100. Perhaps I should increase the number of seconds from 60 to 120?? Just a thought and I would appreciate your opinon. ๐Ÿ’ก ๐Ÿ˜‰ โ“

    Again, thank you for all your help – this has been a major advance for us and the functioning of the office (and WinFax). I would appreciate your answer to the last question.

    #8963

    admin
    Keymaster

    @kaboondy wrote:

    Under the advanced properties, there is an option to “Disconnect a call if idle for more than xx mins. and Cancel a call if not connected within xx secs. The disconnect box is unchecked (hence not selected) but the second option of cancel a call is filled in at 60 seconds – perhaps the call gets cancelled but we should also disconnect – maybe this causes the hangup as well?? Also, I have encountered receipients that have a much longer connect time of almost 1.5 minutes – and had to change the modem initialization string to end in 100. Perhaps I should increase the number of seconds from 60 to 120?? Just a thought and I would appreciate your opinon. ๐Ÿ’ก ๐Ÿ˜‰ โ“ .

    Those specific settings you see in the Windows Control Panel for the modem have no affect in WinFax PRO. If you want to alter those settings in WinFax, you will have add or modify the initialization string setting in WinFax PRO. The initialization string sends commands to the modem to change specific settings.

    The “Cancel a call if not connected within xx sec.” is the same as the setting S7=XX where XX is the value in seconds. Right now you have S7=100 which sets your modem to disconnect during an “outgoing” call if a connection is not made within 100 seconds. The other option is “Disconnect a call if idle for more than xx mins.” This setting is S19=XX where XX is the value in minutes. By default, I believe this option is OFF (set to 0) for the U.S. Robotics modems. You can add S19=1 to set this to 1 minute, but I don’t think this will solve any problem because if WinFax is in a hung state (for some unknown problem), it will not answer calls regardless if your modem had disconnected or not.

    Here is an example if you wanted to change S7=120 and add S19=1 to your current WinFax modem initialization string:
    Line 1: AT&F&D2&C1&H1&R2&I0S7=120
    Line 2: ATS36=0S19=1
    Flow Control: AT&H1&R2&I0

Viewing 15 posts - 1 through 15 (of 35 total)

You must be logged in to reply to this topic.