Fax Software

Community Forums

This topic contains 34 replies, has 0 voices, and was last updated by  admin 5 years, 5 months ago.

Viewing 15 posts - 16 through 30 (of 35 total)
  • Author
    Posts
  • #8964

    kaboondy
    Participant

    @Moderator wrote:

    @kaboondy wrote:

    …….. but I don’t think this will solve any problem because if WinFax is in a hung state (for some unknown problem), it will not answer calls regardless if your modem had disconnected or not.

    Here is an example if you wanted to change S7=120 and add S19=1 to your current WinFax modem initialization string:
    Line 1: AT&F&D2&C1&H1&R2&I0S7=120
    Line 2: ATS36=0S19=1
    Flow Control: AT&H1&R2&I0

    Thank you for the detailed answer.

    1. Can you please clarify if there is any benefit to making the changes suggested by the string above? If there is no predictable benefit – then I probably won’t make any changes to the string – who knows if the change might create another issue.

    2. The main question in my mind is which is the problem –
    A. “… because if WinFax is in a hung state (for some unknown problem),..” – ie WinFax, the program is in a hung state – OR
    B. The modem is in a hung state and then causing the WinFax program to hang – the reason I ask this is because when WinFax is in a hung state – I can not access the modem properties in either WniFax Pro Setup OR the Control Panel – Modem Properties (which I think would have nothing to do with the WinFax program itself). In other words, if the modem is working properly then should I not be able to access the modem properties in Control Panel despite WinFax being crashed?
    C. Is A. and B. really the same thing. I don’t know enough to realise if I am asking a silly question.

    This has been highly educational and I am deeply appreciative of your help and guidance. Thank you. 😀

    #8965

    admin
    Keymaster

    @kaboondy wrote:

    2. The main question in my mind is which is the problem –
    A. “… because if WinFax is in a hung state (for some unknown problem),..” – ie WinFax, the program is in a hung state – OR
    B. The modem is in a hung state and then causing the WinFax program to hang – the reason I ask this is because when WinFax is in a hung state – I can not access the modem properties in either WniFax Pro Setup OR the Control Panel – Modem Properties (which I think would have nothing to do with the WinFax program itself). In other words, if the modem is working properly then should I not be able to access the modem properties in Control Panel despite WinFax being crashed?
    C. Is A. and B. really the same thing. I don’t know enough to realise if I am asking a silly question.

    The S7 time change will work if you need additional time to make a connection to a fax machine. The S19 change probably won’t make any difference

    It is unknown what causes the modem to hang. You could check to see if there is any common denominator, such as a specific caller? or a wrong number/voice call? it appears that it is detecting a incoming ring signal from the modem (“Incoming call…”) but then hangs. This would indicate the modem is actively monitoring incoming calls but fails immediately after initiating some command to the modem. It could be something as simple as a Caller ID string that isn’t being parsed correctly when using TAPI mode.

    #8966

    kaboondy
    Participant

    I can provide an update and clarify as well.

    S7 – relates to the outgoing faxes – WinFax has NEVER hung on an outgoing fax and after I changed the setting to S7=100 – the single receipient who never got my faxes (in the past) – now always gets the faxes with no issues. Hence, I don’t think there would be any benefit to changing the outgoing command string to 120 second (unless I am missing something). WinFax has ONLY ever hung on an incoming fax.

    S19 – you don’t this would help if we make a change here.

    Because WinFax hangs at the begining of the call – no caller information is shown on the Display Status window – screenshot posted on a previous post. Hence there is no way to confirm if this happens with a specific caller. I suspect this happens randomly (unassociated with the identity of a caller) and is an internal problem within our system.

    Update from the past 5 days. Two changes were made to the WinFax server based on advice from the Moderator. A. Turn off the screen saver and B. Set the modem to COM3 and Set the WinFax modem settings to COM3 (instead of TAPI).

    A. The first step was to turn off the screen saver – WinFax hung at the end of the day. This was an inprovement over WinFax hanging after a few hours.
    B. We found the computer was already on COM3 – no change was needed.
    We changed the WinFax Modem properties from TAPI to COM3 – the computer received faxes for 4 days when it hung (on the weekend) while receiving a call.

    Interstingly, when we looked at the Modem properties in WinFax today (after rebooting the computer) – the communication port had CHANGED to TAPI !! Not sure why the change happened spontaneously. In addition the choice of COM3 was not available in the WinFax Modem properties menu !! When I opened the modem in Device Manager – the modem was stil on COM3.

    Another question – does the “initialize at xxxxx bps matter here? Is there an ideal number for this. Also the Modem type – I believe I have a choice of Class 1 vs Class 2. Which one should I select? I could querry the modem and then decide which class based on the report from the modem.

    Thank you for all your asssistance. 🙂

    For now, I have left the setting on TAPI and will see how long it takes for WInFax to hang and will report to you.

    Given the information above, if you have any other suggestions on modifications to try, I would be most grateful. Thank you.

    #8967

    admin
    Keymaster

    The Class 1 or Class 2 settings and initialization speed settings should remain on default settings as selected by WinFax. If you have problems sending or receiving faxes , then you can try Class 2 assuming the modem supports this mode.

    if the com port doesn’t appear in the WinFax drop down option then the modem is not configured properly for WinFax.
    Reconfigure the modem in WinFax by pressing the SHIFT key and clicking properties. This will force WinFax to reconfigure the modem. If that doesn’t work, you might have to remove (from Add/Remove Modem) and then reboot the computer.

    #8968

    kaboondy
    Participant

    I will try this tomorrow and report to the forum. Thank you. 😀

    WinFax reconfigured the modem and it reports it as a Class 1 and Class 2 modem. Here is the screen shot of the report from WinFax

    [attachment=2:3k4spfur]Modem Configuration Wizard WinFax.JPG[/attachment:3k4spfur]

    [attachment=1:3k4spfur]Fax Properties for Modem in WinFax after Config.JPG[/attachment:3k4spfur]

    [attachment=0:3k4spfur]General Properties for Modem in WinFax after Config.JPG[/attachment:3k4spfur]

    I checked the Modem speed and it seemed to have changed from what it was prior to the Wizard reconfiguring the modem (was about 19000). I changed S7=55 to S7=120 for a prior issue. I left the rest of the variables as set by the Wizard (COM port vs TAPI, Class 1 vs Class2, Initialization speed). Given that this might have also contributed to the problem, I will try this for the next few days to see if this is any better. Subsequently, I can try changing the other variables listed above one at a time if instability remains for receiving calls.

    If you have any other thoughts, I would be very appreciative of any directions. Thank you.

    #8969

    kaboondy
    Participant

    I am reporting after several days of trials. WinFax continues to “hang” requiring a reboot after about one day of operating correctly. While this is definitely an improvement over crashing after a few hours, we would really hope to solve this problem for good (if possible).

    I have tried to reset the modem properties in WinFax – I was able to reset by pressing SHIFT and then Properties. The modem did reset and the screen shot for this is shown in the previous post – this is a class 1 and Class 2.0 modem. The program automatically selects Class 1 as the option.

    However, after resetting the modem – the modem properties only show COM 1, COM2 and TAPI as the options for the Port. There is no Option for Com3 on the drop down menu. So I took the next step (below):

    In Device Manager i uninstalled the modem and then rebooted the computer – the modem was autoomatically re-installed on COM3 (was on COM3 originally as well). When I go back to the WinFax Modem properties – I had to reset the modem as WinFax showed an error on startup – “you have not selected a modem device…” However, even after resetting the modem in WinFax – there was still no COM3 option available. Hence it remains on TAPI as selecting COM1 or COM2 will likely result in an error.

    If you have any other suggestions, I would be most appreciative of your help. Thank you. 🙂

    #8970

    admin
    Keymaster

    What IRQ is the modem using? Do you notice that the IRQ number changes after a reboot or uninstall of modem/reinstall? Its possible there is some sort of problem assigning IRQs. Try installing the modem in a different slot, or if you know that COM3, IRQ 5 is not being used you can disable the Plug and Play on the modem and force the modem to use these settings.

    Do you have actual com ports connections on this computer? either 9 pin or 25 pin connectors (if it is an older computer) usually, these are reserved as COM1 and COM2. Some computers only have 1 connector for COM1 and don’t have an actual connection for COM2, but both ports are still reserved. Many new computers within that past 10 years or so don’t have any physical com ports.

    You could try to configure the fax modem to use COM2: IRQ 3 but you have to make sure that you have physical COM2 port disabled on this PC and disable it in the computers bios if that option is available.

    from and older USR Manual…

    Most computers come with two external COM ports (COM1 and COM2). If you have an
    external COM2 connector (look on the back of your computer), you will have a conflict if
    you install an internal modem using COM2. Even if nothing is connected to the external
    port, the COM port is still reserved for that port, unless you disable it in the system
    BIOS. The reason this happens is that the external connector uses a serial interface card,
    which reserves COM2 and IRQ3 for the external connector. If you do not plan to use the
    external COM2 connector, most computers will let you disable it (consult your
    computer’s user guide or its manufacturer’s technical support). Your internal modem may
    then be installed using COM2 and IRQ3, if you choose. Modems are not required to be
    on COM2 and IRQ3, but we are using this as an example.

    Sound cards, network cards, SCSI/IDE, and other serial interface cards use COM
    ports and/or IRQs. You may have installed such a card in your computer’s expansion
    slot to run an external hard drive, or CD-ROM, or perhaps to connect to your
    network. Some video cards also use an IRQ. The main issue to watch for with video
    cards is that many of them share COM4’s memory address space. This can conflict if
    you try putting a modem on COM4. Please contact your graphic card company for
    support on this issue. You need to determine which COM port and IRQ each serial
    interface card in your system is using.

    #8971

    kaboondy
    Participant

    Thank you. This is very educational. I will try all the of the above suggestions and report back in a couple of days. 😀

    #8972

    kaboondy
    Participant

    It has been some time and I have tried a number of variables on both computers.

    1. In the BIOS – I disabled Serial Port A and Serial Port B. Both are not used and hence by disabling them it would free up COM1 and COM2 which are usually assigned to the External Serial Ports A and B.

    2. In Device Manager, under communications, there are listed LPT1 and COM1 and COM2. The COM1 and COM2 (under properties – Advanced Tab), can have their assigned COM ports changed. I changed these to a higher COM – 5 and 6.

    3. In Device Manager, I then changed the COM Port assigned to the Fax Modem from COM3 to COM2 (as this became available when COM1 and COM2 were freed). The IRQ for the Modem is set at 21 and I am unable to change it – there is a Change settings dialogue under Resources Tab but this has only “Settings based on” which appear to have a specifc protocol like 0000, 0001, 0002, 0003 etc which I did not understand and is greayed out. In other words, I can not choose to use a free IRQ (I know that IRQ 4 and 5 are free when I select the View menu in Device Manager to show by Connection.

    4. Once the COM (only) was changed for the Modem – I opened the settings for the Modem in WinFax – There was no option to Select COM2 (which the modem is now installed on). Only TAPI and COM6 show as options in the WinFax modem properties. Hence, despite having the Modem on COM2 – I still have to select TAPI to allow the Modem to work with WinFax since COM2 does not show as an option.

    If there are any futher suggestions, I would be deeply appreciative. I think I have exhausted every option or idea that has been sggested. Perhaps the only thing to do is to reboot the computer at regular intervals to avoid the WinFax from hanging after a few hours. It should be noted that once WinFax hangs, the only way to get it to work again seems to be to reboot the computer. I realize the other way is to close the program(s) in Task Manager. It is interesting that the program does not respond (the Exit option when one right clicks the Message Manager in the Task bar is greyed out so you can not exit the program gracefully. Also, once WinFax has hung, I can not open up the Modem properties in Device Manager at all. In other words the Modem also does not respond either once WinFax has hung.

    Thank you for your help and support on this very perplexing topic.

    #8973

    admin
    Keymaster

    @kaboondy wrote:

    2. In Device Manager, under communications, there are listed LPT1 and COM1 and COM2. The COM1 and COM2 (under properties – Advanced Tab), can have their assigned COM ports changed. I changed these to a higher COM – 5 and 6.

    Should leave these at the default settings.

    @kaboondy wrote:

    It has been some time and I have tried a number of variables on both computers.

    3. In Device Manager, I then changed the COM Port assigned to the Fax Modem from COM3 to COM2 (as this became available when COM1 and COM2 were freed). The IRQ for the Modem is set at 21 and I am unable to change it – there is a Change settings dialogue under Resources Tab but this has only “Settings based on” which appear to have a specifc protocol like 0000, 0001, 0002, 0003 etc which I did not understand and is greayed out. In other words, I can not choose to use a free IRQ (I know that IRQ 4 and 5 are free when I select the View menu in Device Manager to show by Connection.

    You mentioned earlier the modem has a physical setting for Plug and Play mode? Does it have a jumper on the modem board to turn this off?

    @kaboondy wrote:

    4. Once the COM (only) was changed for the Modem – I opened the settings for the Modem in WinFax – There was no option to Select COM2 (which the modem is now installed on). Only TAPI and COM6 show as options in the WinFax modem properties. Hence, despite having the Modem on COM2 – I still have to select TAPI to allow the Modem to work with WinFax since COM2 does not show as an option.

    If there are any futher suggestions, I would be deeply appreciative. I think I have exhausted every option or idea that has been sggested. Perhaps the only thing to do is to reboot the computer at regular intervals to avoid the WinFax from hanging after a few hours. It should be noted that once WinFax hangs, the only way to get it to work again seems to be to reboot the computer. I realize the other way is to close the program(s) in Task Manager. It is interesting that the program does not respond (the Exit option when one right clicks the Message Manager in the Task bar is greyed out so you can not exit the program gracefully. Also, once WinFax has hung, I can not open up the Modem properties in Device Manager at all. In other words the Modem also does not respond either once WinFax has hung.

    #8974

    kaboondy
    Participant

    Thank you for your response.

    Regrettably the Fax modem is a USR plug and play type. I was in error when I stated in an earlier post that there were pins on the modem card that could be changed. At one time, I did have such a fax modem – I can look for it to see if I still have it. If I recall correctly, the modem with the “pin setting option” was an older modem (?? ISA) while the currently installed plug and play was purchased many years later (PCI). To be clear the pins on the (ISA type) modem had two sets of pin options – one to set the COM (1,2 or 3) and IRQ (1 – 7) – if I recall correctly.

    Are you suggesting that I should revert the COM1 and COM2 in the Device manager BACK to COM1 and COM2 (instead of COM5 and COM6)? Please note that the external Serial Port A and B are not used on this computer – If I understand correctly, the COM1 and COM2 are normally reserved for the external Serial A and B ports. Correct?

    No matter what I have tried, I can not seem to be able to see the COM setting in the modem properties in WinFax. Hence, I have had to use the TAPI setting. In other words the modem is installed on COM2 – confirmed by Modem and Communication Devices Properties – Test Com Ports. When I open the properties – COM2 is not an option. In my mind this seems strange because WinFax does see the modem on COM2 but will not communicate with it directly but only through TAPI.

    I am not even sure if all the effort to directly link WinFax to the modem will be helpful in solving this problem even if we are able to somehow get this to happen.

    Any other suggestions would be very much appreciated. I will continue to try on my end and report to the forum (if I am successful) in case someone else has this problem in the future (or currently).

    #8975

    admin
    Keymaster

    @kaboondy wrote:

    Regrettably the Fax modem is a USR plug and play type. I was in error when I stated in an earlier post that there were pins on the modem card that could be changed. At one time, I did have such a fax modem – I can look for it to see if I still have it. If I recall correctly, the modem with the “pin setting option” was an older modem (?? ISA) while the currently installed plug and play was purchased many years later (PCI). To be clear the pins on the (ISA type) modem had two sets of pin options – one to set the COM (1,2 or 3) and IRQ (1 – 7) – if I recall correctly.

    Yes, the older internal ISA modems had these jumper pins to select the modem irq/com port. Some fax modem hardware during the Windows 95 era (1995+) may have have the option to use plug and play or manually select the com port by way of jumper pins. Using an ISA modem probably isn’t a good idea, and very few PC motherboards had both PCI and ISA slots.

    @kaboondy wrote:

    Are you suggesting that I should revert the COM1 and COM2 in the Device manager BACK to COM1 and COM2 (instead of COM5 and COM6)? Please note that the external Serial Port A and B are not used on this computer – If I understand correctly, the COM1 and COM2 are normally reserved for the external Serial A and B ports. Correct?

    yes, leave them as is, (com1) and (com2) if they show up in device manager. there is no need to change them to com5 and com6. What is important is that the com ports are disabled at the BIOS level.

    @kaboondy wrote:

    No matter what I have tried, I can not seem to be able to see the COM setting in the modem properties in WinFax. Hence, I have had to use the TAPI setting. In other words the modem is installed on COM2 – confirmed by Modem and Communication Devices Properties – Test Com Ports. When I open the properties – COM2 is not an option. In my mind this seems strange because WinFax does see the modem on COM2 but will not communicate with it directly but only through TAPI.

    you mentioned earlier that COM6 appeared as an option? it may be because you changed the com2 setting in device manager to com6.

    @kaboondy wrote:

    I am not even sure if all the effort to directly link WinFax to the modem will be helpful in solving this problem even if we are able to somehow get this to happen.

    yes that is true, there is no guarantee that this will solve the problem but I think it is a step in the right direction (without replacing the modem )

    #8976

    kaboondy
    Participant

    Again, thank you.

    If I understand correctly, you suggest that I revert the COM1 and COM2 in the device manager to use Com1 and Com2 respectively in the advanced button under Port Settings Tab. I will go ahead and try this.

    I am not really sure what the COM1 and COM2 in the Device Manager refer to. Then when I open the properties and look into the advanced tab under Port settings – what are the numerous (more than 20 COM settings) that I can scroll and select from refer to? Depending on the computer, some Com ports indicate that it is “used” or allocated. It would be nice to know as I really don’t understand the use of these terms “com ports” in the Properties and COM1 and COM2 headings in Device Manager. Apparently COM1 and COM2 in Device Manager are devices while the ones seen in the Port Tab are “ports“. Can you please explain as I was not able to understand from my search on the internet.

    Thank you

    #8977

    admin
    Keymaster

    Device Manager (at least for Windows 7) show them as “Communication Ports” where they are linked to a port number (COMx), a memory address, an IRQ number. The two communications ports you see in device manager are referring to the two physical hardware interfaces (serial connectors/devices) on your computer. Even when the connector is not present, or if nothing is plugged into the connector they do still exist and are being reserved as COM1, IRQ 4 and COM2, IRQ 3. Only when you disable them at the BIOS level is when they should no longer be reserved and those resources would be available for use by other hardware on your PC.

    #8978

    kaboondy
    Participant

    Thank you.

    I did go into BIOS and disable both the ports and then in Device Manager I reassigned the port numbers to each of the COMs to a higher port number. And it did free up the lower COM ports 1, 2, and 3 as well as the IRQ but I was not able to manually force the computer to select the lower IRQ’s for the Fax Modem.

    It is curious that despite being disabled in the BIOS the “communication Ports” still show in Device Manager implying that they are still “active”. I had assumed the COM1 and COM2 must be referring to some other devices rather than the physical, external harware Serial Ports on the computer which I had disabled.

    I will reverse the changes and report back. Thanks again.

Viewing 15 posts - 16 through 30 (of 35 total)

You must be logged in to reply to this topic.