Fax Software

Community Forums

This topic contains 9 replies, has 0 voices, and was last updated by  Anonymous 12 years, 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3481

    wysocki
    Member

    I upgraded my PC to XPsp2 and now I get the dreaded TCP/IP not installed error from Winfax. I’ve done all the fixes I could find, deinstalled, installed 10.03 the the 10.04 patch and still can’t get it going. Add to all this the fact that Symantec does not support the product anymore and it’s time to find something else.

    Does anyone know of a good alternative that supports fax sharing?

    #6926

    Anonymous
    Member

    Did you try removing TCP/IP in Windows XP and reinstalling it?

    #6927

    wysocki
    Member

    Yes, however with XP you can’t really deinstall/reinstall TCP/IP. All you can do is reset it with NETSH. I’ve done that to no avail. Currently, after I deinstalled everything, then reinstalled 10.03 and 10.04, whenever I start the computer I get the setup script for CSID and the user info. I fill it out but it keeps asking each time I startup. Also, whenever I go to setup the client for fax sharing I get the TCP/IP Not Installed message. This is before I even get the chance to specify the fax server. I’ve read through all the great posts on the GetFaxing forums plus anything I could find at Symantec and Google and I’m stumped.

    I’ve tried a couple of network fax systems but they really suck! Waaaay to complex for me. I just want a simple system (like Winfax was) to work with one phone line on one machine. I curse Microsoft (for SP2) and Symantec (for buying and dropping Winfax).

    #6928

    Anonymous
    Member

    EDIT: Please see http://support.microsoft.com/kb/811259/

    For the TCP/IP not installed message, you might want to try the following:

    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. In Registry Editor, locate the following keys, right-click each key “Winsock” and “Winsock2”, and then click Rename:

    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesWinsock
    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesWinsock2

    Rename to “WinsockOld” and “Winsock2old”

    go into networking setup and just make sure TCP/IP is configured.
    It should recreate a new set of Winsock and Winsock2 keys.
    then try the Host Sharing in WinFax.

    Let me know if that works, and then we can fix the CSID , Fax Number problem.

    Edited By Moderator on 1163303982

    #6929

    wysocki
    Member

    I renamed both registry keys then rebooted. The computer hung for a LONG time upon startup and a couple of apps complained about Winsock2 not being installed. After if finally came up, I check regedit and the Winsock2 key was rebuilt but the Winsock key was not. After a few reboots with the same results, I renamed both OLDs back to the originals and rebooted but the computer still hung (about 5 minutes to see desktop) and complained about Winsock2 missing. I had no Internet connectivity on that machine. On another machine I found a utility on the web called WinsockXPFix.exe and (thru the network) ran it from the damaged PC. It DID fix the problem and it now boots fine again. However, Winfax still complains about the TCP/IP problem when I try to config the fax sharing client.

    #6930

    Anonymous
    Member

    I found this document, http://support.microsoft.com/kb/811259/
    but it appears you’ve done everything already included here.
    but I noticed with SP2, there is the netsh command “netsh winsock reset catalog” Is this what you tried?
    check this:
    http://www.microsoft.com/technet….x#E5AAE
    under “TCP/IP”

    netsh winsock reset catalog

    This command resets the Winsock catalog to the default configuration. This can be useful if a malformed LSP is installed that results in loss of network connectivity. While use of this command can restore network connectivity, it should be used with care because any previously-installed LSPs will need to be re-installed.

    Edited By Moderator on 1163303823

    #6931

    wysocki
    Member

    I hadn’t tried the reset catalog before so I tried it, but still no luck. I’ve also run the guided help to restore Winsock2 and tried the manual method too. Thinking that maybe my Winfax install disks were bad, I tried a fresh install of 10.03 on my notebook and it works fine there (XPsp2). I’m even able to install the fax sharing client without upgrading it to 10.04. I don’t understand why all of my networking and Internet access works fine over TCP/IP but Winfax can’t do it. I”m on the verge of formatting the hard drive and just reinstalling everything (arggggh!).

    I really appreciate your help here. Too bad Symantec doesn’t give a damn.

    #6932

    Anonymous
    Member

    when do you see the error message about TCP/IP not installed? is it when you double-click the WinFax Client Sharing in the Setup, or when you click “WinFax Fax/Message Sharing” under Modems and Communications devices?

    I did a registry monitor and it also looks at this key

    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParameters

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParameters]
    "NV Hostname"="P4-2GHZ"
    "DataBasePath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,
     00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,
     64,00,72,00,69,00,76,00,65,00,72,00,73,00,5c,00,65,00,74,00,63,00,00,00
    "NameServer"=""
    "ForwardBroadcasts"=dword:00000000
    "IPEnableRouter"=dword:00000000
    "Domain"=""
    "SearchList"=""
    "UseDomainNameDevolution"=dword:00000001
    "EnableICMPRedirect"=dword:00000001
    "DeadGWDetectDefault"=dword:00000001
    "DontAddDefaultGatewayDefault"=dword:00000000
    "EnableSecurityFilters"=dword:00000000
    "AllowUnqualifiedQuery"=dword:00000000
    "PrioritizeRecordData"=dword:00000001
    "Hostname"="P4-2GHZ"

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersAdapters]

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersAdaptersNdisWanIp]
    "LLInterface"="WANARP"
    "IpConfig"=hex(7):54,00,63,00,70,00,69,00,70,00,5c,00,50,00,61,00,72,00,61,00,
     6d,00,65,00,74,00,65,00,72,00,73,00,5c,00,49,00,6e,00,74,00,65,00,72,00,66,
     00,61,00,63,00,65,00,73,00,5c,00,7b,00,31,00,34,00,36,00,35,00,33,00,36,00,
     37,00,32,00,2d,00,37,00,34,00,42,00,44,00,2d,00,34,00,32,00,30,00,35,00,2d,
     00,39,00,34,00,37,00,39,00,2d,00,44,00,41,00,43,00,38,00,35,00,42,00,44,00,
     41,00,32,00,45,00,46,00,46,00,7d,00,00,00,54,00,63,00,70,00,69,00,70,00,5c,
     00,50,00,61,00,72,00,61,00,6d,00,65,00,74,00,65,00,72,00,73,00,5c,00,49,00,
     6e,00,74,00,65,00,72,00,66,00,61,00,63,00,65,00,73,00,5c,00,7b,00,33,00,31,
     00,34,00,45,00,45,00,45,00,43,00,44,00,2d,00,36,00,41,00,37,00,33,00,2d,00,
     34,00,44,00,39,00,44,00,2d,00,41,00,45,00,46,00,45,00,2d,00,32,00,33,00,38,
     00,34,00,42,00,36,00,39,00,36,00,32,00,34,00,32,00,45,00,7d,00,00,00,54,00,
     63,00,70,00,69,00,70,00,5c,00,50,00,61,00,72,00,61,00,6d,00,65,00,74,00,65,
     00,72,00,73,00,5c,00,49,00,6e,00,74,00,65,00,72,00,66,00,61,00,63,00,65,00,
     73,00,5c,00,7b,00,45,00,35,00,37,00,31,00,35,00,37,00,43,00,37,00,2d,00,46,
     00,35,00,39,00,35,00,2d,00,34,00,44,00,34,00,31,00,2d,00,39,00,32,00,31,00,
     43,00,2d,00,46,00,45,00,33,00,36,00,43,00,44,00,46,00,44,00,41,00,45,00,34,
     00,39,00,7d,00,00,00,54,00,63,00,70,00,69,00,70,00,5c,00,50,00,61,00,72,00,
     61,00,6d,00,65,00,74,00,65,00,72,00,73,00,5c,00,49,00,6e,00,74,00,65,00,72,
     00,66,00,61,00,63,00,65,00,73,00,5c,00,7b,00,34,00,33,00,35,00,37,00,30,00,
     44,00,44,00,37,00,2d,00,41,00,34,00,42,00,35,00,2d,00,34,00,32,00,42,00,36,
     00,2d,00,38,00,45,00,37,00,39,00,2d,00,36,00,33,00,30,00,39,00,45,00,38,00,
     35,00,44,00,35,00,41,00,42,00,34,00,7d,00,00,00,00,00
    "NumInterfaces"=dword:00000004
    "IpInterfaces"=hex:72,36,65,14,bd,74,05,42,94,79,da,c8,5b,da,2e,ff,cd,ee,4e,31,
     73,6a,9d,4d,ae,fe,23,84,b6,96,24,2e,c7,57,71,e5,95,f5,41,4d,92,1c,fe,36,cd,
     fd,ae,49,d7,0d,57,43,b5,a4,b6,42,8e,79,63,09,e8,5d,5a,b4

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersAdapters{55BEC173-4A71-442F-85BF-640B558ED871}]
    "LLInterface"=""
    "IpConfig"=hex(7):54,00,63,00,70,00,69,00,70,00,5c,00,50,00,61,00,72,00,61,00,
     6d,00,65,00,74,00,65,00,72,00,73,00,5c,00,49,00,6e,00,74,00,65,00,72,00,66,
     00,61,00,63,00,65,00,73,00,5c,00,7b,00,35,00,35,00,42,00,45,00,43,00,31,00,
     37,00,33,00,2d,00,34,00,41,00,37,00,31,00,2d,00,34,00,34,00,32,00,46,00,2d,
     00,38,00,35,00,42,00,46,00,2d,00,36,00,34,00,30,00,42,00,35,00,35,00,38,00,
     45,00,44,00,38,00,37,00,31,00,7d,00,00,00,00,00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersDNSRegisteredAdapters]

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces]

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{14653672-74BD-4205-9479-DAC85BDA2EFF}]
    "UseZeroBroadcast"=dword:00000000
    "EnableDHCP"=dword:00000000
    "IPAddress"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "SubnetMask"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "DefaultGateway"=hex(7):00,00
    "EnableDeadGWDetect"=dword:00000001
    "DontAddDefaultGateway"=dword:00000000

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{314EEECD-6A73-4D9D-AEFE-2384B696242E}]
    "UseZeroBroadcast"=dword:00000000
    "EnableDHCP"=dword:00000000
    "IPAddress"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "SubnetMask"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "DefaultGateway"=hex(7):00,00
    "EnableDeadGWDetect"=dword:00000001
    "DontAddDefaultGateway"=dword:00000000
    "NTEContextList"=hex(7):00,00
    "DhcpIPAddress"="0.0.0.0"
    "DhcpSubnetMask"="0.0.0.0"
    "Domain"=""
    "NameServer"=""
    "DisableDynamicUpdate"=dword:00000000
    "EnableAdapterDomainNameRegistration"=dword:00000000

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{43570DD7-A4B5-42B6-8E79-6309E85D5AB4}]
    "UseZeroBroadcast"=dword:00000000
    "EnableDHCP"=dword:00000000
    "IPAddress"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "SubnetMask"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "DefaultGateway"=hex(7):00,00
    "EnableDeadGWDetect"=dword:00000001
    "DontAddDefaultGateway"=dword:00000000
    "NTEContextList"=hex(7):00,00
    "DhcpIPAddress"="0.0.0.0"
    "DhcpSubnetMask"="0.0.0.0"
    "Domain"=""
    "NameServer"=""
    "DisableDynamicUpdate"=dword:00000000
    "EnableAdapterDomainNameRegistration"=dword:00000000
    "RegistrationEnabled"=dword:00000001
    "RegisterAdapterName"=dword:00000000
    "DhcpClassIdBin"=hex:

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{55BEC173-4A71-442F-85BF-640B558ED871}]
    "UseZeroBroadcast"=dword:00000000
    "EnableDeadGWDetect"=dword:00000001
    "EnableDHCP"=dword:00000000
    "IPAddress"=hex(7):31,00,39,00,32,00,2e,00,31,00,36,00,38,00,2e,00,30,00,2e,00,
     33,00,00,00,00,00
    "SubnetMask"=hex(7):32,00,35,00,35,00,2e,00,32,00,35,00,35,00,2e,00,32,00,35,
     00,35,00,2e,00,30,00,00,00,00,00
    "DefaultGateway"=hex(7):31,00,39,00,32,00,2e,00,31,00,36,00,38,00,2e,00,30,00,
     2e,00,31,00,00,00,00,00
    "DefaultGatewayMetric"=hex(7):31,00,00,00,00,00
    "NameServer"="204.101.251.1,209.226.175.236,204.101.251.2"
    "Domain"=""
    "DisableDynamicUpdate"=dword:00000000
    "EnableAdapterDomainNameRegistration"=dword:00000000
    "InterfaceMetric"=dword:00000001
    "TCPAllowedPorts"=hex(7):30,00,00,00,00,00
    "UDPAllowedPorts"=hex(7):30,00,00,00,00,00
    "RawIPAllowedProtocols"=hex(7):30,00,00,00,00,00
    "NTEContextList"=hex(7):30,00,78,00,30,00,30,00,30,00,30,00,30,00,30,00,30,00,
     32,00,00,00,00,00
    "DhcpServer"="255.255.255.255"
    "Lease"=dword:00000e10
    "LeaseObtainedTime"=dword:3d7a4603
    "T1"=dword:3d7a4d0b
    "T2"=dword:3d7a5251
    "LeaseTerminatesTime"=dword:3d7a5413
    "IPAutoconfigurationAddress"="0.0.0.0"
    "IPAutoconfigurationMask"="255.255.0.0"
    "IPAutoconfigurationSeed"=dword:00000000
    "AddressType"=dword:00000000
    "DhcpClassIdBin"=hex:
    "RegistrationEnabled"=dword:00000001
    "RegisterAdapterName"=dword:00000000

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersInterfaces{E57157C7-F595-4D41-921C-FE36CDFDAE49}]
    "UseZeroBroadcast"=dword:00000000
    "EnableDHCP"=dword:00000000
    "IPAddress"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "SubnetMask"=hex(7):30,00,2e,00,30,00,2e,00,30,00,2e,00,30,00,00,00,00,00
    "DefaultGateway"=hex(7):00,00
    "EnableDeadGWDetect"=dword:00000001
    "DontAddDefaultGateway"=dword:00000000

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersPersistentRoutes]

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpipParametersWinsock]
    "UseDelayedAcceptance"=dword:00000000
    "HelperDllName"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,
     6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,
     00,77,00,73,00,68,00,74,00,63,00,70,00,69,00,70,00,2e,00,64,00,6c,00,6c,00,
     00,00
    "MaxSockAddrLength"=dword:00000010
    "MinSockAddrLength"=dword:00000010
    "Mapping"=hex:0b,00,00,00,03,00,00,00,02,00,00,00,01,00,00,00,06,00,00,00,02,
     00,00,00,01,00,00,00,00,00,00,00,02,00,00,00,00,00,00,00,06,00,00,00,00,00,
     00,00,00,00,00,00,06,00,00,00,00,00,00,00,01,00,00,00,06,00,00,00,02,00,00,
     00,02,00,00,00,11,00,00,00,02,00,00,00,02,00,00,00,00,00,00,00,02,00,00,00,
     00,00,00,00,11,00,00,00,00,00,00,00,00,00,00,00,11,00,00,00,00,00,00,00,02,
     00,00,00,11,00,00,00,02,00,00,00,03,00,00,00,00,00,00,00

    The other keys it looks at are:

    HKLMSystemCurrentControlSetServicesWinSock2
    HKLMSYSTEMCurrentControlSetServicesWinsockParameters
    HKLMSystemCurrentControlSetServicesDnsCacheParameters

    maybe you can look at what is different between these keys in the working and non-working system.

    Edited By Moderator on 1163448968

    #6933

    wysocki
    Member

    Well, it finally works!!! I went through both computers and compared the registries (whew) with much difficulty in the keys that have a string like {55BEC173-4A71-442F-85BF-640B558ED871} in the key.

    I didn’t make any changes there because the keys weren’t exactly the same on your list or any of my computers. I think the significant changes I made were:

    "UseDomainNameDevolution"=dword:00000001
    "EnableICMPRedirect"=dword:00000001

    These were not in the failing computer and when I added them and rebooted, I was able to configure the client! I’m still puzzled why the notebook works with 10.03 and my desktop took so much work even with 10.04 which was itself supposed to fix the problem. Thanks again for working through this!

    #6934

    Anonymous
    Member

    Excellent, i looked up those two keys:

    UseDomainNameDevolution

    http://www.microsoft.com/technet….fr=true

    and,

    EnableICMPRedirect

    http://technet2.microsoft.com/Windows….fr=true

    Did these two keys already exist on the failing machine? were they set to 0?

    I’ll see if I can make my setup fail by changing those values.

    edit: I couldn’t make it fail with the tcp/ip error by changing these values, or by removing them (i renamed them)
    however, I did rename the entire TCPIP key and then WinFax reported the error of TCP/IP not being installed, so I couldn’t find the key is specifically fails on. When you rename that key, It appears Windows automatically creates a new TCPIP key (which will then kill your TCPIP settings in Windows) You then need to rename the new TCPIP key to something else, and then rename original key back to TCPIP and reboot Windows for your TCP/IP connection to work again.

    Edited By Moderator on 1163478527

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.