Fax Software

Community Forums

This topic contains 31 replies, has 0 voices, and was last updated by  kaboondy 6 years, 11 months ago.

Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
    Posts
  • #9472

    kaboondy
    Participant

    Thank you. Unfortunately, I do not have (I think) useful information to report. The WIn Xp Client and WIN2K Host issue remains a problem.

    When Windows Firewall is active (there is no other 3rd party firewall present on any computer), the error message is as follows: “WinFax Pro is unable to connect to the WInFax Host station. RPC server is unavailable. No computer with this name has been found on your network”

    Yet, when we open Windows explorer on the WIN XP client, we can see the Host computer and the shared drive on it as well. Another note is that when I tried to PING the Host station in DOS Prompt – there was a failure.

    When reviewing the Event Log in System – there were NO DCOM errors reported.

    When Windows Firewall is shut off on the XP client, WInFax works perfectly. In the Exceptions list I have listed the Controller as well as the Ping program. Perhaps I should list them for all computers rather than those on the subnet only. Please note – all the computers are on the same subnet.

    I am sorry I am not able to provide useful information and I am also confused with this scenario. Thank you for your continued help. If you have further ideas or suggestions, I would be most appreciative.

    #9473

    admin
    Keymaster

    Other WinFax clients running W2K are connecting to this W2K WinFax Host?
    If you disable the Windows Firewall on the Windows XP client, it connects to the Windows 2K WinFax Host?
    What is the IP address of the Host? and what is the IP address of the Windows XP client?
    What version of WinFax PRO are you using on the XP client?
    What version of WinFax PRO are you using on the W2K Host?

    #9474

    kaboondy
    Participant

    Thank you.

    1. Yes, there are 4 WIN2K client computers connected to the WIN2K host. This has been operational for the past several years with no connection issues.
    2. Disabling the Windows Firewall on the WIN Xp computer completely resolves the problem and re-enabling the Win Firewall reliably and consistently reproduces the problem. The WIN Xp client works very well with the WIN Firewall disabled.
    3. The WIn firewall on the XP client has the execptions of the Controller and WFXPING (have tried both for the subnet as well as all computers in the customization).
    4. The IP address of the Host is 192.168.1.66 while that is the client is 192.168.1.73 (both can PING each other with no problems). Both have the same subnet (I think).
    5. All computers – Win2K Host and Win2K clients and WIn XP client have WinFax 10.03 installed
    6. The error message when WIN Firewall is turned on – relates to the RPC server not available as the message states that the computer Host with the name stated does not exist on the network. This is strange as the computer can be PING’ed in DOS prompt as well as seen in Win Explorer while the Firewall is active. I am sure the WIN Firewall must be creating a block of some sort.

    Thank you once again for your suggestions and interest.

    #9475

    admin
    Keymaster

    Ok, below are the required steps for the Windows XP Client PC only. I assume these steps you have already tried. Try it again, but this time, when you reach # 8 in the 3rd section, you want to remove ANONYMOUS LOGON and then add in back in (as noted below)

    In the section ” enable machine wide, remote access to COM for Anonymous Logon users” in step 8, you might need to select “ANONYMOUS LOGON” and click “REMOVE”. Then click OK. Then go back to “Edit Limits”, click ADD. Type in “ANON” in the box and click OK (it should automatically add ANONYMOUS LOGON back as group name) then select ANONYMOUS LOGON and make sure both “Local Access and Remote Access ” to set to “Allow” (both checked)

    To add the WinFax Controller program to the Windows Firewall Exceptions list.

    1 On the Exceptions tab, click Add Program.
    2 Select Controller. The "Path:" box displays a path that ends in Wfxctl32.exe.
    3 If the host and client are on the same network (subnet), click Change scope and select My network (subnet) only.
    4 Click OK, and then click OK again.
    5 In the Programs and Services list, ensure that the box next to Controller is selected.
    6 Click OK, and close the Windows Control Panel.

    To enable Remote Administration traffic through the Firewall by enabling RPC and DCOM

    1.From the Start menu, select All Programs > Accessories > Command Prompt.
    2.Type netsh
    3.Type firewall
    4. If the host and client are on the same subnet, type:
    set service REMOTEADMIN ENABLE SUBNET

    otherwise, type:
    set service REMOTEADMIN ENABLE ALL

    5.Type show service and verify that Remote Administration is enabled.
    6.Type exit and then type exit again.
    To enable machine wide, remote access to COM for Anonymous Logon users
    1.From the Start menu, click Settings > Control Panel.
    2.If using the Classic View, double-click Administrative Tools. Otherwise, click Performance and Maintenance, and then double-click Administrative Tools.
    3.Double-click Component Services.
    4.From the Console Root, open Component Services > Computers > My Computer.
    5.If you see a Security Alert dialog box, click Unblock.
    6.Right-click My Computer, and click Properties.
    7.In the My Computer Properties dialog box, on the COM Security tab, in the Access Permissions group, click Edit Limits.
    8.In the Access Permission dialog box, choose ANONYMOUS LOGON, and select Allow on the Remote Access entry.
    9.Click OK, and then click OK again.
    10.Close the Component Services window and the Administrative Tools window.
    #9476

    kaboondy
    Participant

    I will complete this setting again (I already did this twice) and report back to you. I suspect that if I opened this window and closed it – I might have corrupted the settings as stated in another section of the forum by someone’s very detailed post. I did not think about that possibility until your post.

    Thank you and I will report back after the long weekend.

    #9477

    kaboondy
    Participant

    As you have done in the past suggestions – you were absolutely correct! Doing the settings once again and then carefully exiting resulted in a functioning connection between Win XP client computer and WIN2K Host (with the Windows Firewall turned ON). Thank you once again.

    I have one additonal question relating to the install – I would like to have all the client computers use the Shared Phonebook rather than the local phonebook. It seemed that when logged onto a client computer, if I clicked on the shared phonebook (once connected to), the WinFax program would continue to use the Shared Phonebook. However, when we log out of WinFax and then restart (the next day for example), the program goes back to using the local phonebook.

    Is there a way to force a client computer to only use the Shared phonebook. With 5 client computers, it is much easier to update one shared phonebook rather than 5 local phonebook every time there is an additonal entry.

    Thank you once again for your continued help and support. This has been a very positive experience. You have solved many of the problems with the use of WinFax and improved our efficiency.

    #9478

    admin
    Keymaster

    @kaboondy wrote:

    As you have done in the past suggestions – you were absolutely correct! Doing the settings once again and then carefully exiting resulted in a functioning connection between Win XP client computer and WIN2K Host (with the Windows Firewall turned ON). Thank you once again.

    I have one additonal question relating to the install – I would like to have all the client computers use the Shared Phonebook rather than the local phonebook. It seemed that when logged onto a client computer, if I clicked on the shared phonebook (once connected to), the WinFax program would continue to use the Shared Phonebook. However, when we log out of WinFax and then restart (the next day for example), the program goes back to using the local phonebook.

    Is there a way to force a client computer to only use the Shared phonebook. With 5 client computers, it is much easier to update one shared phonebook rather than 5 local phonebook every time there is an additonal entry.

    Thank you once again for your continued help and support. This has been a very positive experience. You have solved many of the problems with the use of WinFax and improved our efficiency.

    Glad to hear that worked for you.

    For the shared read-only phone book, you need to create a 2nd phone book on each client that is “linked” to the “shared” phone book you created on the Host. If you delete the local (unwanted) phone book, an empty default (local) phone book will always re-appear on the clients. There is no way to change this. The default (locally stored) phone book will always appear, just make sure that everyone using WinFax understand that adding new contacts should only be done on the Host phone book, and not within the local phone book.

    #9479

    kaboondy
    Participant

    This is interesting information. For the past year, I found that the Shared Phonebook became the default phonebook when (while on the client computer) I clicked on the Shared Phonebook and then closed the window. This was not a formal setting change but simply clicking on the phonebook (when there is a local and Shared Phonebook) in the menu. Once this was done, WinFax chose the Shared Phonebook first by default saving the time/trouble of having to chose it manually for each sent fax dialogue. This “setting” change remained in effect even after shutting down and starting the computer the next day. In other words, it seemed to be a permanent change until recently. I wonder if I deleted the shared phonebook and recreated it, if it would revert the system back to the above function.

    On the other hand, this remains partially true even now – once we click on the Shared Phonebook – as long as the program remains active, the “default” phone book remains the Shared Phonebook. If we exit the program (complete shutdown and exit from the program), then we have to chose the Shared Phonebook again.

    This change seemed to occur after we worked on the XP – Win2K issues although I can not see how that would be related.

    Thank you once again for your help.

    #9480

    admin
    Keymaster

    WinFax doesn’t actually have a “default” phone book setting. I was referring the locally stored phone book that WinFax creates when you install WinFax, Symantec calls this the default phone book.

    As you mentioned, WinFax will (or should) remember the last phone book that was open (in the Phone book window in the Send dialog screen) and in the Phone book window. It does this automatically, so there is no setting to save.

    All this phone book specific information in the Send Screen is stored in the Windows Registry
    HKEY_CURRENT_USERSoftwareDelrinaWinfax7.0PhonebookSendFaxSpreadSettings

    Perhaps there is something wrong with the entries stored in this registry location.
    You can reset all the Phone book registry settings easily on the Win XP client by doing the following:

    Start WinFax PRO Message Manager.
    Click Tools , Maintenance Utility.
    Click Restore Default Settings
    Scroll down the list to “Phonebooks MDI settings” and select this option.
    Click Reset.

    #9481

    kaboondy
    Participant

    @Moderator wrote:

    As you mentioned, WinFax will (or should) remember the last phone book that was open (in the Phone book window in the Send dialog screen) and in the Phone book window. It does this automatically, so there is no setting to save.

    All this phone book specific information in the Send Screen is stored in the Windows Registry
    HKEY_CURRENT_USERSoftwareDelrinaWinfax7.0PhonebookSendFaxSpreadSettings

    Perhaps there is something wrong with the entries stored in this registry location.
    You can reset all the Phone book registry settings easily on the Win XP client by doing the following:

    Start WinFax PRO Message Manager.
    Click Tools , Maintenance Utility.
    Click Restore Default Settings
    Scroll down the list to “Phonebooks MDI settings” and select this option.
    Click Reset.

    This is very helpful information. But can you please clarify. When you said

    WinFax will (or should) remember the last phone book that was open (in the Phone book window in the Send dialog screen) and in the Phone book window. It does this automatically, so there is no setting to save.

    Do you mean that it should remember the Shared Phonebook was the last Phonebook used even after the program is restarted (or computer is re-booted the next day)?

    I will review the registry settings in each of the client computer and report to you. You did not state however what the registry field

    HKEY_CURRENT_USERSoftwareDelrinaWinfax7.0PhonebookSendFaxSpreadSettings

    should be filled with (especially in the Win2K clients).

    Also, would making the change in the XP Client as you suggested using the Maintainance Utility in WinFax – would this simply revert the client computer back to the local “My Phonebook”? Are you suggesting that I then select the Shared Phonebook on the Host and see if the client “remembers” this as the Phonebook to use after the program has been reset? A clarification would be helpful in terms of what I can expect. Thank you.

    #9482

    admin
    Keymaster

    Yes, the last phone book that was opened is stored in the registry key I described. The data that appears in this key is generated by WinFax and it depends on what phone book is selected and what position the window is. It will appear as a series of Hex numbers.
    When the Send dialog is open, this information is retrieved by WinFax and the last phone book folder that was open will appear in the right window of the send dialog. If for some reason the phonebook is not available, or the registry key is incorrect then this may not happen.

    The maintenance tool will reset (erase) these values of that specific registry location for you. The next time you start WinFax, select the phone book you want to always open and the next time you start WinFax, it should open that same phone book first.

    If that doesn’t work, then a possible reason is that your network location isn’t available immediately upon boot up and log in of your computer. Other than that, I am not sure why it wouldn’t work for you.

    #9483

    kaboondy
    Participant

    Wonderful and thank you. I think you are saying ‘I can have my cake and eat it too’. I will attempt your solution and report back to you. My steps will be –

    1. Turn on the server FIRST and see if this solves the problem (to ensure the connection is established on bootup).
    2. If this does not work, then I will clear the registry value in the WIN2K clients and use the Maintance Utility for the XP client to clear the registry.

    I will report back in a couple of days. Thank you once again.

    #9484

    kaboondy
    Participant

    I can now report the following:

    1. Turning the server on first did not make any difference to the selection of the Phonebook (the local default My Phonebook was selected by each computer)
    2. Clearing the registry was an easy step but did not make any difference. Once the registry was cleared, the program was reopened, send dialogue activated, Shared Phonebook selected and fax was sent. The program was closed, then reopened and the send dialogue reopened to find the My phonebook was again selected. I should note that once the Shared Phonebook is selected, it remains selected for future faxes as long as the WinFax session remains active. If the program is turned off (or the computer reboots) the default My Phonebook is again selected.

    In the past once the Shared Phonebook was selected, it remained the pre-selected option in the Send fax dialogue (top right window) even after a reboot.

    I am sorry this did not work. I have another idea but did not have time to try it. I will delete the Shared phonebook and recreate it and see if this help and will report back. There may be a problem at that end. I have come to realize that we settings can get corrupted easily. I will report to the forum. Thank you.

    #9485

    admin
    Keymaster

    I could not reproduce this problem with a shared phonebook. WinFax always opened the shared phonebook first. Try deleting the shared phonebook on the client and re-add it. Is your network connection wired, or wireless?

    #9486

    kaboondy
    Participant

    You are absolutely right. Deletion of the shared phonebook and recreating (took very little time) and also solved the problem. yes, the shared phonebook has now become the default phonebook for all the client computers on the network. Thank you once again for all your help. This has been amazing.

Viewing 15 posts - 16 through 30 (of 32 total)

You must be logged in to reply to this topic.