Fax Software

Community Forums

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3981

    I am using Winfax 10.04 in a network shared configuration. What ports does Winfax use on the clients and host? I am also using an HL7 program to obtain information from another service that sends the information over the internet and to the client via an HL7 program. The program uses port 10000. I have noticed some communication link failures with the HL7 program. Could winfax be causing this?

    Thank you.


    winfax uses DCOM to communicate with clients/hosts, it uses a random ports above 1024 that are available.

    WinFax PRO and TalkWorks PRO does not use fixed TCP or UDP ports when using Fax or Message Sharing. Fax Sharing is accomplished using Microsoft DCOM technology. DCOM dynamically assigns one TCP port and one UDP port to each executable process serving DCOM objects on a computer. DCOM initially uses Port 135, once this connection is established, other ports are used. To ensure proper Fax Sharing, you need to ensure port 135 is not blocked and that wfxctl32.exe process is not blocked in your firewall or anti-virus settings.

    from http://www.getfaxing.com/winfax/2009/08/18/tcp-and-udp-ports-for-winfax-pro-or-talkworks-pro-fax-sharing/

    I found this on Microsoft’s site, I guess you can try restricting ports that DCOM uses, but I have no idea if this works.

    Restricting the Range of TCP Ports

    There are several registry settings that control the DCOM port restriction functionality. All of the named values listed below are located under the HKEY_LOCAL_MACHINESoftwareMicrosoftRpcInternet registry key (which you must create). Remember that you only need to do this on the server machine. Clients will automatically pick up the right port numbers when they connect to the SCM on the server machine.

    from this page, http://msdn.microsoft.com/en-us/library/ms809327.aspx


    Thank you, I’ll give it a try.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.