Fax Software

Community Forums

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2637
    solentb
    Member

    Hi,

    Can you help us with winfax? We use Winfax Pro 10 with one PC as a ‘server’ with 5 ‘clients’ all on XPSP3. Last week all the clients have stopped being able to connect to the server with various errors including:

    Winfax pro sharing client error.
    The object exporter specified was not found.

    Winfax cannot connect to Winfax PRO on Jake-dell (Reason: Access is denied.). Check that this is the correct host name.

    I can’t really understand what has gone wrong with it all. I have tried re-doing the various fixes to make winfax work with service pack 2 and 3.

    #4448
    admin
    Keymaster

    Before doing anything, I recommend checking the Windows event viewer log on the Host computer to check for any error messages related to DCOM. You’ll get an error report at the time when the WinFax client(s) attempt to connect to the Host. This could be something simple as a firewall or anti-virus blocking a port used by DCOM.

    #4449
    solentb
    Member

    I looked in the event viewer are there are lots of these errors. It doesn’t make sense as I made the required changes to allow the ‘ANONYMOUS LOGON’ access to remote activation of DCOM. Here is the error:


    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10021
    Date: 31/01/2013
    Time: 09:27:02
    User: N/A
    Computer: JAKE-DELL
    Description:
    The launch and activation security descriptor for the COM Server application with CLSID
    {17EAB2A0-70E2-11CE-A7FB-008029E0ABE9}
    is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed. This security permission can be corrected using the Component Services administrative tool.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.



    Hope you can clear this up.

    #4450
    solentb
    Member

    OK so I checked the settings for com security again and they look like this:


    Which should be OK I think.

    When I go into DCOM Config I get these messages though. Should I say yes?



    I don’t understand how it can be working in the morning and not in the afternoon. I’ve been having problems with one of the clients which would work one day and then not the next and now none of the clients will connect. I have been able to keep Winfax clients and server working for about 10 years on win 98 and XP but this is being a problem for me.

    #4451
    admin
    Keymaster

    the dcom error you report from the Host’s event log is similar to the problem and solution posted here:
    viewtopic.php?f=18&t=1745
    I would expect that you’ve updated something on that system that caused the original DCOM security settings to be invalid, it may have been a Microsoft update.
    The dcom configuration warning messages are common, you can click “No” to those messages. It has nothing to do with WinFax and the Host setup.

    #4452
    solentb
    Member

    Thanks. Do I have to pay to read that post?

    #4453
    admin
    Keymaster

    Sorry I assumed you had access to the premium section, if you have an active subscription you would have access to all the forums.

    Here is simple condensed version of the post:

    NOTE: THIS IS DONE ON THE HOST WinFax PC ONLY!

    From the Start menu, click Settings > Control Panel.
    If using the Classic View, double-click Administrative Tools. Otherwise, click Performance and Maintenance, and then double-click Administrative Tools.
    Double-click Component Services.
    From the Console Root, open Component Services > Computers > My Computer > DCOM Config.
    From the menu, click View > Detail.
    From the DCOM Config list, right-click WinFax.Attachment, and click Properties.
    On the Security tab, in the Launch and Activation Permissions group, select Customize, and click Edit.
    Select the “ANONYMOUS LOGON” user then click REMOVE. (This is existing entry that we need to remove)
    Click Add, type ANONYMOUS LOGON and click OK. (We create a new ANONYMOUS LOGON entry)
    Choose ANONYMOUS LOGON, and select Allow on the Remote Activation entry. All other boxes should be deselected.
    Click OK, and then click OK again.
    Close the Component Services window and the Administrative Tools window.

    That should correct the specific DCOM error message “The launch and activation security descriptor for the COM Server application with CLSID
    {17EAB2A0-70E2-11CE-A7FB-008029E0ABE9} is invalid. It contains Access Control Entries with permissions that are invalid.”

    If there are other problems then they will be shown as a different DCOM error message in the event log or shown on the individual client PC’s event log.

    #4454
    solentb
    Member

    Thanks. That has helped indirectly. I did try that but it still would not work.

    After much tinkering with various things I uninstalled winfax and then installed it again. Then I re-did all the firewall and rpc and dcom tweaks and finally it works. For now.

    I did try the fax talk demo and it works well (it just works and imports winfax data easily) but the boss does not like it as much as winfax so I have to keep on keeping on making winfax work!

    Thanks for helping.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.