Fax Software

Community Forums

This topic contains 4 replies, has 0 voices, and was last updated by  admin 12 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3544

    transition
    Member

    :angry:

    I am a small business owner (tech saavy, but not an MCSE or network administrator). I am having untold problems connecting with WinFax Host Sharing. A brief history. I had a Windows 2000 Professional Host (named Server) and 3 workstations (Clients) with Windows XP Pro. I recently replaced my aging server with an updated computer from Dell for reliability reasons. All computers are Windows XP Pro, SP 2 (installed from the factory), using Windows Firewall, Trend Micro PC-Cillin 2006 on 2 Client computers, 2007 on Host Computer and one other Client computer. PC-Cillin firewall is turned off on all computers.

    I have joined this posting and read most everything on here related to this issue. Here are the various things I have undertaken:

    Installed WinFax 10.03 on the new Host, followed Symantec’s step-by-step procedure to get it to work with SP2. Didn’t work: Error Message – Denied Access – Check that this is the correct host name. It is. I believe the problem was I had 10.04 on client workstations.

    Uninstalled WinFax on all machines using Add/Remove Programs. Set-up Host with 10.03, followed Symantec’s procedure once again. Installed 10.03 on client workstation. Followed Symantec’s procedure once again. Didn’t work: Error Message – Denied Access – Check that this is the correct host name. This is true even if Windows Firewall was off on both machines. I could ping the host computer named server. Tried to put the IP Address in directly (192.168.1.7) and that didn’t work either. Have a password at the host that I input into Client sharing. Have adminstrator users set-up on both Host and Client workstation. oleaut32.dll is the same version on both Host and Client.

    Uninstalled WinFax on all machines using Add/Remove Programs. Set-up Host with 10.03, followed Symantec’s procedure once again EXCEPT I used John Nadeau’s “Possible Fix for Connecting to Host”. Installed 10.03 on Client Workstation, followed Symantec’s procedure. Didn’t work: Error Message – Denied Access – Check that this is the correct host name.

    Uninstalled WinFax on all machines using Add/Remove Programs. Set-up Host with 10.03, followed Symantec’s procedure once again and again, used John Nadeau’s posting. Installed 10.04 patch and followed Symantec’s procedure to the T. Installed 10.03 on Client Workstation, followed Symantec’s procedure once again. Installed 10.04 patch and followed Symantec’s procedure again. Didn’t work: Error Message – Denied Access – Check that this is the correct host name.

    I am almost to the point of tears, seriously. I have looked at other fax options but nothing gives my clients the confidentiality as point-to-point faxing capabilities. I have looked into fax to email but it is not secure.

    Some more miscellanous thoughts that may help diagnose my issue:

    – I found on another forum (http://www.serverfiles.com) that adding port “1090” to your firewall worked for someone else. I tried that, didn’t work, same error message
    – I have restricted my installs/unistalls to the host and one client computer
    – In my many unistalls, reinstalls, I have checked and double checked what I was clicking, typing, etc. It cannot be a typo, I am a detailed little sucker.

    #7209

    transition
    Member

    A couple more things

    – I have added the Controller (WFXCTL32.exe), WFXPING.exe and WFXMOD32.exe to the exceptions list in Windows firewall at both the Host and the Client workstation

    – In the scenarios above (except the first, my mistake), I have had exactly the same version of WinFax running on both the host and client workstation (ie. 10.03 or 10.04 but not 10.03 on host and 10.04 on client)

    #7210

    admin
    Keymaster

    I would eliminate the 10.04 update, and do not update from 10.03 to 10.04. It will only complicate the troubleshooting process. If you already installed 10.04, I’d recommend you uninstall, and reinstall 10.03. After uninstalling and reinstalling WinFax, you have to reapply the steps listed in the Symantec fax sharing document for Windows XP, for the Host and the client. (Recommend you only work with 1 host and 1 client)

    It appears you have already tried these steps, but I mention it just incase.

    Do you have any errors specific to DCOM in the Host and client machines Event Viewer? This can give you a clue of what is happening.

    Also, Port 1090 may have been a blocked port by a firewall, if it is, unblock it. I don’t think this port is usually blocked by default, and I believe this port is commonly used with Real Networks video, and perhaps this specific user had this port blocked preventing people from watching videos from the Internet using Real Networks. DCOM (using by WinFax Fax Sharing) also uses the port range of 1090-1110, so WinFax may have been using 1090, and that is likely why it “fixed” this specific users problem.

    Its also possible a hardware firewall is blocking ports that may be used by DCOM, such as Port 135 inbound ??

    #7211

    transition
    Member

    😀

    Well thanks to you folks and another tip I found online, I got my WinFax Pro Sharing to Work on Windows XP Machines with SP2. See my previous post “At the point of tears” for more details. This has taken me about 30 hours to figure out (yes, we tracked our time). I hope this will alleviate the pain the rest of you may be experiencing.

    Here is how I got it to work step by step. I just did it and came on here to share it all with you while it is still fresh in my mind:

    HOST COMPUTER
    1. Took the advice of moderator and decided to just try and get 10.03 working first. Unistalled 10.04 on the host, deleted anonymous login from Component Services- Dcom, deleted all WinFax exceptions from Windows firewall. Rebooted and installed 10.03. You then have to reboot. Please note, I did not install host sharing at this point, just the modem on my file server.

    2. Took the Symantec instructions “Fax Sharing client cannot connect to host after Installing Windows XP SP2” and followed them to a T, rebooting along the way as instructed. However, I did take the additional step of add the WFXPING.EXE to my exceptions as well at that time.

    3. I then found on another site the following EXTRA steps.

    Step 5: Final Instructions
    All the instructions above should be applied to all computers. It may not be necessary to apply them to all computers, but it is thorough. Make sure that all computers are on the same workgroup and that all computers have file sharing enabled. I would share at least one folder on each computer to verify that file sharing is enabled. Check that you can see the shared folders on all the comptuers. To check go to Start Menu > Run > Type “\PcName” where PcName is the name of the computer you want to view. If a window pops up with a list of shares on that computer then file sharing is properly enabled. You may also need to create a user on the host computer for each client. The new user must match the username and password of the client’s currently logged in username and password. The users created must have administrator rights. Be sure to restart all computers have making these changes.

    If you have trouble after following my steps please see below:

    Optional Final Step: More DCOM Config
    This step may also be needed to get winfax working.
    Start Menu > Run > Type “dcomcnfg”
    From the Console Root, open Component Services > Computers > My Computer.
    Right-click My Computer, and click Properties.
    In the My Computer Properties dialog box, on the “Default Properties ” tab, make sure the box “Enable Distributed COM on this computer” is checked. Then set the “Default Authentication Level” box to “None” and the “Default Impersonation Level” to “Anonymous”. Then click ok and restart. You may have to do this on all computers.

    Registry Tweak That May Be Required
    Cut and paste the following (between the lines) into notepad and save as something like RPC_ON.REG. Double click to activate file:


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\RPC] “EnableAuthEpResolution”=dword:00000001
    “RestrictRemoteClients”=dword:00000000

    To Reverse the RPC changes later, if needed, use the following in a registry file called RPC_OFF.REG


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\RPC] “EnableAuthEpResolution”=dword:00000000
    “RestrictRemoteClients”=dword:00000001

    Re-boot the computer and good luck!

    I did check to see that I could see the client computer from the host. I did the “Optional Final Step” at the host and rebooted. I did not do the registry tweaks.

    4. After all of this was done, I then enabled Host Sharing on my Host computer.

    CLIENT WORKSTATION

    1. Unistalled 10.04, deleted the anonymous logon, deleted the Winfax exceptions from Firewall. Rebooted.

    2. Installed 10.03 and when it asked me to set up, I bypassed setting up the “Client Sharing” option. Rebooted.

    3. Took the Symantec instructions “Fax Sharing client cannot connect to host after Installing Windows XP SP2” and followed them to a T, rebooting along the way as instructed. I just did steps 1-4 and then 7 because I was at a Client computer. Rebooted.

    4. Did the extra step at the Client computer as outlined below:

    Optional Final Step: More DCOM Config
    This step may also be needed to get winfax working.
    Start Menu > Run > Type “dcomcnfg”
    From the Console Root, open Component Services > Computers > My Computer.
    Right-click My Computer, and click Properties.
    In the My Computer Properties dialog box, on the “Default Properties ” tab, make sure the box “Enable Distributed COM on this computer” is checked. Then set the “Default Authentication Level” box to “None” and the “Default Impersonation Level” to “Anonymous”. Then click ok and restart.

    5. After rebooting, I went to enable Client sharing and got the dreaded error “Access Denied – Check that this is the correct host name” Not disheartened, I went to step #6.

    6. Implemented John Nadeau’s fix on this forum. Specifically, I went back to the host and clicked allow on all 4 entries

    “… Local Launch, Remote Launch, Local Activation, Remote Activation (whereas Symantec said to only select Remote Activation)”

    in Component Services – My Computer – DCOM Config – Winfax Attachment.

    7. Went back to the Client computer and tried to set up Client Sharing and low and behold, it connected, it let me finish setting up the client workstation and we could now see faxes on the Host.

    I would welcome any comments on whether this “extra step” now makes my computer a higher security risk.

    Final notes

    – I am not going to upgrade to 10.04. If it ain’t broke, don’t fix it.
    – I didn’t open any ports on the host and deleted the open port I had before (1090)
    – didn’t check that my oleaut32.dll was the same (was using a different client this time)

    I hope this helps you all.

    #7212

    admin
    Keymaster

    Good to hear you’ve resolved it, 30 hours is a frustrating long time to work on this one, and I know troubleshooting this can be frustrating. That would have worked out to $1 an hour for your time, if you used our Live Support service!

    We’ve never had to use these steps you’ve mentioned below, so I am not sure if these are recommended:

    “….Then set the “Default Authentication Level” box to “None” and the “Default Impersonation Level” to “Anonymous”. Then click ok and restart. You may have to do this on all computers.

    Registry Tweak That May Be Required
    Cut and paste the following (between the lines) into notepad and save as something like RPC_ON.REG. Double click to activate file:”

    btw, i moved your new post and merged it with this existing topic

    Edited By Moderator on 1187807345

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.