Fax Software

Community Forums

This topic contains 13 replies, has 0 voices, and was last updated by  JohnD 9 years, 6 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #3999

    Pilot
    Member

    I have Winfax Pro 10.03. The system was working fine until we came to work this morning and none of the clients were able to connect to the host. The host does not have any problems because it is receiving faxes as it normally does. I ran antivirus and antispyware scans but that didn’t help.

    The exact error message is :Winfax Pro is unable to connect to the Winfax PRo Host station called (Host Station Name). Make sure an account has been created for you on the host station (using the same name/password used to login to your client station).

    My antivirus is Avast and Antispyware is Spybot Search and Destroy.

    I would appreciate it if anyone would help. ❓

    #8812

    JohnD
    Participant

    If all the clients cannot connect, then it is likely a problem specific with the Host PC.
    Assuming nothing was changed on the client PCs.

    Try –
    Turn off WinFax (exit Controller) in each client, then reboot the Host PC.
    Once the Host reboots and the WinFax Controller is active on the Host, you can then attempt to connect with one client.

    Problems could be:
    – If you have logged in the Host with a different user, then you may receive this error.
    – If you made any WinFax PRO configuration changes on the Host, such as Tools, Setup, Fax Sharing Host.
    – Updated to Service Pack 2 or 3 (Windows XP)

    To troubleshoot: On Host machine, check Event Viewer and see if there are any DCOM related error messages. (Usualy this will show up with a Red X )

    #8813

    Pilot
    Member

    I already restarted Controller on the host and clients, restarted the host and clients, but it still won’t let the clients connect.

    I did not have any of the problems you mentioned in your post:
    ” Problems could be:
    – If you have logged in the Host with a different user, then you may receive this error.
    – If you made any WinFax PRO configuration changes on the Host, such as Tools, Setup, Fax Sharing Host.
    – Updated to Service Pack 2 or 3 (Windows XP)

    To troubleshoot: On Host machine, check Event Viewer and see if there are any DCOM related error messages. (Usualy this will show up with a Red X )”

    I did check the Event Viewer, and under System there are many DCOM Errors with event numbers 10021 or 10016, where some say Anonymous Logon and others say N/A, starting yesterday, which is when the problem started.

    How do I fix the problem?

    Thanks 🙁

    #8814

    JohnD
    Participant

    I did check the Event Viewer, and under System there are many DCOM Errors with event numbers 10021 or 10016, where some say Anonymous Logon and others say N/A, starting yesterday, which is when the problem started.

    Ok, those errors are likely due to a problem with the DCOM WinFax.Attachment settings for Anonymous Logon. It looks like you may have to RE-APPLY this setting:

    Follow these steps on the HOST computer ONLY (WinFax PRO 10.03, Windows XP SP3 or SP2)

    Enable Anonymous Logon users to have remote activation access to the WinFax.Attachment DCOM component

    From the Start menu, click Settings > Control Panel.
    If using the Classic View, double-click Administrative Tools. Otherwise, click Performance and Maintenance, and then double-click Administrative Tools.
    Double-click Component Services.
    From the Console Root, open Component Services > Computers > My Computer > DCOM Config.
    From the menu, click View > Detail.
    From the DCOM Config list, right-click WinFax.Attachment, and click Properties.
    On the Security tab, in the Launch and Activation Permissions group, select Customize, and click Edit.
    Click Add, type ANONYMOUS LOGON and click OK.
    Choose ANONYMOUS LOGON, and select Allow on the Remote Activation entry. All other boxes should be deselected.
    Click OK, and then click OK again.
    Close the Component Services window and the Administrative Tools window.

    #8815

    Pilot
    Member

    Ok, those errors are likely due to a problem with the DCOM WinFax.Attachment settings for Anonymous Logon. It looks like you may have to RE-APPLY this setting:

    Follow these steps on the HOST computer ONLY (WinFax PRO 10.03, Windows XP SP3 or SP2)

    Enable Anonymous Logon users to have remote activation access to the WinFax.Attachment DCOM component

    From the Start menu, click Settings > Control Panel.
    If using the Classic View, double-click Administrative Tools. Otherwise, click Performance and Maintenance, and then double-click Administrative Tools.
    Double-click Component Services.
    From the Console Root, open Component Services > Computers > My Computer > DCOM Config.
    From the menu, click View > Detail.
    From the DCOM Config list, right-click WinFax.Attachment, and click Properties.
    On the Security tab, in the Launch and Activation Permissions group, select Customize, and click Edit.
    Click Add, type ANONYMOUS LOGON and click OK.
    Choose ANONYMOUS LOGON, and select Allow on the Remote Activation entry. All other boxes should be deselected.
    Click OK, and then click OK again.
    Close the Component Services window and the Administrative Tools window

    I checked and these settings are all exactly the way, so I did not have to edit anything.
    Or do you want me to delete ANONYMOUS LOGON and close the window and add it again.
    Would that work?
    Or could it be something else?

    #8816

    JohnD
    Participant

    Yes, re-apply the settings. Remove anonymous user and add it back in.

    #8817

    Pilot
    Member

    OK, it worked. I appreciate it very much….Thank you.

    Do you know why this happens and how I can prevent it? It was working fine and then it stopped working.

    Thank you again. 😀

    #8818

    JohnD
    Participant

    Glad to hear it worked.

    If you change a setting in Setup , WinFax Fax Sharing Host, and click “OK” it can cause this.

    but Its possible something else caused made changes to reset DCOM security settings.

    #8819

    @pilot wrote:

    The system was working fine until we came to work this morning and none of the clients were able to connect to the host. The host does not have any problems because it is receiving faxes as it normally does. I ran antivirus and antispyware scans but that didn’t help.

    The exact error message is :Winfax Pro is unable to connect to the Winfax PRo Host station called (Host Station Name). Make sure an account has been created for you on the host station (using the same name/password used to login to your client station).

    I have virtually exactly the same problem, except that in my case, fax sharing still works if, but only if, the client is a member of Administrators on the host computer (running XP Pro).

    I also have loads of DCOM errors in the Events log saying

    The launch and activation security descriptor for the COM Server application with CLSID
    {17EAB2A0-70E2-11CE-A7FB-008029E0ABE9}
    is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed. This security permission can be corrected using the Component Services administrative tool.

    I have tried removing and re-adding Anonymous Logon rights to the winfax attachment but it has not made any difference.

    Can you suggest anything else? I have spent hours trying to puzzle out what has gone wrong, but to no avail so far!

    Thanks,

    #8820

    Following on from my previous post, I have just tried resetting Winfax Fax Sharing on one of the problem clients and this generated the following error in the Events Log

    The machine-default permission settings do not grant Remote Activation permission for the COM Server application with CLSID
    {DA4E5220-FE02-11D0-BD2E-00805F98AB78}
    to the user NT AUTHORITYANONYMOUS LOGON SID (S-1-5-7). This security permission can be modified using the Component Services administrative tool.

    Since I have just reset the Anonymous Logon rights to the Winfax attachment in DCOM Config, how can this possibly be? Do the “machine-default permission settings” override the changes I have made? If so, can I change the “machine-default permissions”, whatever they are?

    #8821

    To save anyone wasting any time on this, I have solved it myself!

    From the Events log, I followed the link to Microsoft’s Help and Support and followed the instructions – which were basically the same as before.

    In DCOM Config, I gave full rights to Anonymous Logon (Winfax.Attachment item), and then tried connecting again – it worked!

    I then removed the rights one by one until just Remote Activation remained (which was how it was set before I started), and it still worked!

    Just for reference, I would mention that my configuration is Winfax 10.0 on the Windows XP host (not 10.02, 10.03 or 10.04 – 10.0 was not supposed to work on Windows XP, but it most certainly does!), with Winfax 9.03 on the clients.

    I hope this information helps someone else.

    #8822

    JohnD
    Participant

    @highlysceptical wrote:

    Since I have just reset the Anonymous Logon rights to the Winfax attachment in DCOM Config, how can this possibly be? Do the “machine-default permission settings” override the changes I have made? If so, can I change the “machine-default permissions”, whatever they are?

    After you reapplied the Anonymous Login setting for the WinFax.Attachment object, if at any time you go back into WinFax Host Sharing setup and click OK . you will cause this error to occur. Do not go back into the WinFax Host Settings to change options. Any change to this dialog (or simply clicking OK) will cause this error. If you need to go into this dialog box to view settings, you can but only if you click CANCEL to exit. If you make any change, like adding or changing a host sharing password … it will require you to re-do the Anonymous User settings for the WinFax.Attachment object. Like I mentioned earlier in this thread, there could be other causes for this but simply clicking OK from the WinFax Host setup dialog box will de-activate the DCOM settings for WinFax.Attachment.

    Version 10 will indeed work with XP. However, I am not sure how you are getting a 10.00 Host to work with 9.03 clients. I haven’t tried this before but under normal conditions it shouldn’t allow it.

    #8823

    @johnd wrote:

    Version 10 will indeed work with XP. However, I am not sure how you are getting a 10.00 Host to work with 9.03 clients. I haven’t tried this before but under normal conditions it shouldn’t allow it.

    Well, as I said, it most certainly does work. All I have done is to :-

    apply the changes to the firewall, DCOM Config etc. as per the Symantec guidance
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Print on the host
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Winfax Ports on the host
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Winfax Ports (Photo Quality) on the host
    granted user permissions to c:windows on the host

    And thanks for the additional information.

    #8824

    JohnD
    Participant

    @highlysceptical wrote:

    Well, as I said, it most certainly does work. All I have done is to :-

    apply the changes to the firewall, DCOM Config etc. as per the Symantec guidance
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Print on the host
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Winfax Ports on the host
    granted user permissions to HKLM/Microsoft/Windows NT/CurrentVersion/Winfax Ports (Photo Quality) on the host
    granted user permissions to c:windows on the host

    I’m curious, The printer drivers should be installed locally on the clients when you installed 9.03, so I am not sure why you would need to grant user permissions on the Host machine for the “Print”, “WinFax Ports” and “WinFax Ports (Photo Quality)” registry keys. The Host doesn’t even need the WInFax printer drivers instaled to operate (unless you are actually generating the faxes from the Host machine)
    or did you do this so multple users logging on the Host machine have access to WinFax, and the WinFax printer?

    Version 10.0x of WinFax checks to see the Host version before it allows a connection , Its possible that there is no such check in WinFax PRO 9.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.