Fax Software

Community Forums

This topic contains 13 replies, has 0 voices, and was last updated by  Anonymous 13 years, 1 month ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #3449

    Anonymous
    Member

    I have Win 2000 Pro on all machines w/Winfax 10.02. Fax sharing works fine – as long as the host is logged on. Winfax host is set to “leave running when logged off”.

    When the host logs off, the host cannot auto send or auto receive. When the host logs back on, Winfax locks up when loading the controller.

    Any suggestions?

    Gary Reid

    #6797

    Anonymous
    Member

    The WinFax Service is what is active when you log off Windows. The service must be set to Automatic, and started.
    You can confirm this setting in the Control Panel Administrative Tools, Services.

    The service is located here:
    C:WINNTsystem32WFXSVC.EXE

    The WinFax service only has the ability to send (whatever items are already in the outbox) and receive faxes while logged off, it does not notify other clients of a fax received nor does it automatically print faxes you’ve received etc.

    As for the lock up, I’d try rebuilding the log files (using the Maintenance Tool in WinFax PRO). If that doesn’t work, you may want to move the log files completely and have WinFax recreate a new log structure. This will delete all your entries in the send, receive and outbox folders. The log structure files start with the name STATUS (status.wfb, status.wfx etc.)

    Here is the On-Line help entry about the WinFax Service:

    The WinFax PRO NT/2000/XP service allows you to receive incoming faxes and schedule faxes to be sent when you are logged out of Windows NT/2000/XP. You do not need this service to use WinFax when you are logged onto Windows NT/2000/XP.

    By default, the Setup program installs the Windows NT/2000/XP service when it detects you are using Windows NT/2000/XP 4.0. This service loads automatically whenever you start Windows NT/2000/XP. If you have power-user or administrative privileges, you can start or stop the NT/2000/XP service from the Windows Control Panel if necessary.

    To use the Windows NT/2000/XP service, you must:

    1. load the Windows NT/2000/XP service (loads automatically when you start Windows NT/2000/XP)

    2. enable automatic reception in Message Manager or in the Controller

    3. enable Send And Receive Faxes When Logged Off (start Program Setup and double click Call Status And Controller)

    If you are using the Windows NT/2000/XP service and you want to be notified of new faxes you receive when you are logged out, enable Notify in the Receive Properties dialog (start Program Setup, double click Receive, and then click the After Receive tab).

    #6798

    Anonymous
    Member

    Thank you for your prompt reply. All my settings seem correct.

    I found that if I disable the wfxsvc service, I can log out and back in no problem – the controller seems fine. If I set the service to auto, log out and log back in, winfax locks up when I log back in. Rebuilding didn’t help.

    So I renamed all 7 “Status.*” files to status1.* & rebooted. The controller starts up fine. The service starts fine, and I can log out and log back in without a lock up, with the service running, which is good.

    However, since I renamed all the status files, the Outbox, Send Log, Receive Log and Wastbasket have all disappeared completely. Winfax did not recreate these files. Winfax does try to answer calls, even when I’m logged off, which is good, but Winfax doesn’t like this too much because there are no folders to put anything in and I get some “can’t find file” errors.

    If I restore all the status files back to their original name, I get the same problem again.

    The answer to my problem seems to be with 1 or more of these “status” files. I don’t have any user data worth saving, so is there something I can do with these status files that will give me a clean slate, so to speak.

    Thank you in advance.

    Gary Reid

    #6799

    Anonymous
    Member

    Yes. move all the status*.* files to another directory for backup, or you can delete them completely if you don’t need the data. Make sure the Service, the Controller and WinFax is not running when you delete or move them.

    When you re-start WinFax and the Controller, those status*.* files will be recreated new. The logs will be empty and you should be OK.

    #6800

    Anonymous
    Member

    Since my last post, I went to the Symantec site to lean how to recreate status/log files from scratch, which I did, and now I’m back to square 1.

    The host can’t receive when logged off & when I do log back on, Winfax stops responding. Got to use the Task Manager to kill it.

    Funny thing is, when the status files didn’t exist at all, Winfax at least attemped to answer calls after I logged off (although unsuccessfully do to the “missing files”), and when I did log back on, the controller came right up (again, with some missing file errors).

    There is something about those status files. You can’t tell what’s in these files or the purpose.

    Could this have something to do with the “user” that installed Winfax and the current user being different? All users have admin privilages.

    Sure appreciate your help.

    Gary Reid

    #6801

    Anonymous
    Member

    Yes, permissions may be not set for the user. You might want to try these steps

    http://symantec.atgnow.com/consume….e=5000#

    #6802

    Anonymous
    Member

    I already added all the users to regacces.

    I just installed PCAnywhere (on it’s own modem), which autoloads a “listening controller” upon boot (simiilar to the Winfax controller). It doesn’t answer an incoming call unless you close/restart the PCAnywhere contoller.

    It appears that there is something about how both programs initialize their corresponding modems.

    Winfax won’t answer a call unless you do a clean boot (if you log off & on, it locks up).

    PCAnywhere won’t answer a call unless you close/restart it’s controller after
    a clean boot.

    Something about the boot process and/or log on process that causes these programs to loose track of their modems…

    Maybe this is beyond the scope of this forum.

    Thanks again.

    Gary Reid

    #6803

    Anonymous
    Member

    Both WinFax and pcAnywhere use TAPI to communicate with the modem. Its possible there is something wrong there.

    Have you tried installing WinFax while logged on as Administrator, and then log on/off as Administrator to see if the auto answer when Logged off works?

    As for pcAnywhere, you should try deleting the existing host entry and re-adding a new host and make sure its set to start with Windows and have it run as a service. Might be worth a try.

    #6804

    Anonymous
    Member

    All my system users are admins.

    I’m now in the process of reinstalling both Winfax & PCAnywhere, all ports, all modems, all dial up connections – one modem at a time, one program at a time…

    I didn’t use passwords in Winfax, on the host, or on the cleints. I’ll do that this time, plus I’m doing the whole installation under one user name.

    I’ll let you know…

    Thanks for your tips.

    Gary Reid

    #6805

    Anonymous
    Member

    The saga continues…

    I did get PCAnywhere to work. It was the “load with windows” check box that fixed it. Back to Winfax…

    I did a reinstall of Winfax (10.03 now) with 1 Com port & 1 modem – all under the same admin user.

    For troubleshooting, I chose to start the controller manually (durng setup) and I also installed a 33.6 external modem which has all the TX RX status lights.

    When I boot the machine, and I’m at the login screen, the modem status lights indicate “ready to receive” as the Winfax service initializes in the background. Only the service is loaded at this point and it does indeed receive faxes before logging on. Great.

    I continue to log on as a user, the modem is still ready. (Note that the controller is NOT running.) If I immediately log back off, the modem is still good to go & it receives faxes after I’ve logged off. Very good.

    Up to this point, I can receive faxes before logging on and I can receive faxes after logging back off. Note that I have not yet started the controller at all yet – not even once.

    Now I add the controller to the mix:

    I log on, and I start the controller. Everything works fine. I can stop & restart the controller just fine. Now, I’m ready to log off, so I manually stop the controller, and log the user off & I’m back to the login screen.

    At the login screen, I notice that the modem is no longer “ready to receive” and it doesn’t receive faxes. Prior to using the controller, the modem was always in a “ready” state at the login screen.

    So I log the user back on, but when I try to start the controller, Message Manager tries to load the controller – and then it locks up. I have to kill Winfax with the task manager. Winfax will not run again without a reboot.

    I can be logged off & receive faxes – providing that I did not start the controller at all while I was logged on. And if I do run the controller & log off, I can no longer receive while I’m logged off, plus I can’t restart the controller without rebooting.

    I tried other modems. I tried using Com 1 instead of TAPI. (Under Win 2000 Pro, the Telephony service has nothing to configure.) I tried different init strings for the modems, specifically a reset init string. I re-created all the log/status files.

    Prior to the reinstall, I had the controller load via startup instead of manually. My guess is the Winfax service always did work while I was logged off, but I couldn’t receive because the controller had been run first.

    Seems like its something with how the controller releases and/or resets the modem when the controller is closed??? Doesn’t seem to be TAPI as I have the same problem bypassing TAPI. Are there some registry entries worth checking or changing?

    I’ve got a lot invested in this problem. I’m not ready to give up quite yet. Any help would be greatly appreciated.

    Gary Reid

    #6806

    Anonymous
    Member

    Under Call Status and Controller (in Setup) do you have the option “Allow sending and receiving while logged off” turned on? Just checking….

    adjusting init strings isn’t going to help.

    When you log off after you’ve succesfully started the controller, and then log back on, are you logging in as the same user? and as soon as you start the Controller the system hangs?

    #6807

    Anonymous
    Member

    Thank you for your quick response.

    “Sending & receiving…when logged off” is checked, and does work – provided that I have not run the controller at all when I do log on.

    I make a point of logging in as the same admin user every time (the same user that installed Winfax to begin with). I have not tried it under a different user.

    If I boot the machine, when the login screen comes up, I can receive faxes before I log in, which indicates that the Winfax service is working. Likewise, if I log in & log out – without starting the controller while logged in – it receives when I log back out, which again, indicates that the Winfax service is working.

    But if I log in, start the controller, and log out, the Winfax service does not work when I log back out. It doesn’t matter if I close the controller manually or let the OS close it. Then, if I immediately log back in, the controller won’t load. I see it in the taskbar (auto receive disabled). If I right click on it, I get nothing, so I start Message Manager and it locks up at the point where it initializes the controller. The system doesn’t hang, just Winfax. Once I kill Winfax, the system still works and I can even use the same modem to connect to the internet, etc. The only way to get Winfax to work again is a reboot.

    From what I understand, the controller has control when logged on. The service has control when logged off. Seems to be an issue with how the controller closes & releases the modem, so the service can take over when you log off.

    How the modem fits into this changeover, I have no idea. Because of the status lights on my modem, I do know that you can see the service initialize the modem when you first boot up. When you start the controller, the status lights don’t even flicker. They remain in the “ready” mode, which is all good. When you close the controller, the status lights indicate a “not ready to receive” state, which you would expect. Then, when you log off & the service takes control, you would expect the modem to be “ready” again, but it isn’t. It stays in the “not ready” state.

    It there a way to audit any of this or create a log? Does Winfax create it’s own log?

    Could this be a DCOM issue? A security issue? Anything to check here?

    I really appreciate your time on this. Symantec support was no help at all.

    Gary Reid

    #6808

    Anonymous
    Member

    @gary wrote:

    Thank you for your quick response.

    “Sending & receiving…when logged off” is checked, and does work – provided that I have not run the controller at all when I do log on.

    I make a point of logging in as the same admin user every time (the same user that installed Winfax to begin with). I have not tried it under a different user.

    If I boot the machine, when the login screen comes up, I can receive faxes before I log in, which indicates that the Winfax service is working. Likewise, if I log in & log out – without starting the controller while logged in – it receives when I log back out, which again, indicates that the Winfax service is working.

    But if I log in, start the controller, and log out, the Winfax service does not work when I log back out. It doesn’t matter if I close the controller manually or let the OS close it. Then, if I immediately log back in, the controller won’t load. I see it in the taskbar (auto receive disabled). If I right click on it, I get nothing, so I start Message Manager and it locks up at the point where it initializes the controller. The system doesn’t hang, just Winfax. Once I kill Winfax, the system still works and I can even use the same modem to connect to the internet, etc. The only way to get Winfax to work again is a reboot.

    From what I understand, the controller has control when logged on. The service has control when logged off. Seems to be an issue with how the controller closes & releases the modem, so the service can take over when you log off.

    How the modem fits into this changeover, I have no idea. Because of the status lights on my modem, I do know that you can see the service initialize the modem when you first boot up. When you start the controller, the status lights don’t even flicker. They remain in the “ready” mode, which is all good. When you close the controller, the status lights indicate a “not ready to receive” state, which you would expect. Then, when you log off & the service takes control, you would expect the modem to be “ready” again, but it isn’t. It stays in the “not ready” state.

    It there a way to audit any of this or create a log? Does Winfax create it’s own log?

    Could this be a DCOM issue? A security issue? Anything to check here?

    I really appreciate your time on this. Symantec support was no help at all.

    Gary Reid

    When you log back on, (before starting the Controller) what applications are active in your task manager?

    then start the controller and check the tasks again. Then close the controller, and check the tasks. Do you have a left over occurance of “WinFax MOD ” or wfxmod32″ running?
    or multiple copies of it?

    There is also a debug mode you can enable to see what the modem is doing.

    To enable Debug Mode

    Exit all open programs and stop the WinFax PRO service
    Click Start, point to Find, and click Files or Folders. The Find dialog box appears.
    From the Look In drop-down list, select the drive on which you installed WinFax PRO/TalkWorks PRO.
    Check Include subfolders (if not already checked.)
    In the Named field, type:

    symdiag.exe

    and click Find Now. Windows displays all files matching the search criteria.
    Double-click the found file. You will receive notification that this should only be used with the direct assistance of a technician and to proceed with caution.
    Click OK, click Enable/Disable features. Select Debug Mode (Currently Disabled,) and click Enable. The display will change to Debug Mode (Currently Enabled.)
    Click Close, and click Close again. You will be asked if you would like to launch the Message Manager. Click Yes.

    NOTE: When you launch the Controller with Debug mode enabled, you will receive a Fax/Modem alert indicating that the debug mode is enabled. The name of the log file is called .log and is located in the Data directory.

    To disable Debug Mode

    Exit all open programs and stop the WinFax PRO serviceClick Start, point to Find, and click Files or Folders. The Find dialog box appears.
    From the Look In drop-down list, select the drive on which you installed WinFax PRO/TalkWorks PRO.
    Check Include subfolders (if not already checked.)
    In the Named field, type:

    symdiag.exe

    and click Find Now. Windows displays all files matching the search criteria.
    Double-click the found file. You will receive notification that this should only be used with the direct assistance of a technician and to proceed with Caution.
    Click OK, click Enable/Disable features. Select Debug Mode (Currently Enabled), and click Disable. The display will change to Debug Mode (Currently Disabled.)
    Click Close, and click Close again. You will be asked if you would like to launch the Message Manager. Click Yes.

    #6809

    Anonymous
    Member

    Out of town for a week… You asked about active applications/processes in the Task Manager.

    (1) Upon boot, the application winfaxmod is running. Processes are wfxsvc, wfxsnt40 & wfxmod32. This all seems right.

    When I start the controller, the above are running, plus the wfxctl32. This also seems right.

    When I stop the controller, I have the wfxsvc & wfxsnt40 only, which makes sense.

    (2) I can receive after boot & before log on. After log on, I can receive before I even start the controller (didn’t know I could do that). If I log back off – without starting the controller – I can receive.

    If I do start the controller, I can receive. But if I log off & on, the controller & Message Manager freeze, requiring a reboot.

    I also noticed that I can use the Task Manager to manually start & stop WinfaxMod – as long as the controller hasn’t been run yet.

    (3) I am assuming that after you boot, winfaxmod is loaded prior to log on. And it stays running until you stop the controller.

    When you stop the controller winfaxmod is unloaded. When you log off, what happens to winfaxmod? When the service takes over, does winfaxmod get reloaded? It appears it isn’t.

    (4) Regarding the Symdiag Debug Mode, it seems this only logs activity when the controller is running. My problem is after the controller closes, so this log didn’t shed any light on the problem. Everything in the log looked normal.

    (5) Could this be a permission issue? I have Winfax sharing enabled (which works fine), but I noticed the permissions for the above files vary from one machine to another. What should the permissions be for these files?

    (6) In summary, everything works fine, but I can’t log off & back on – Winfax freezes.

    Thanks again,
    Gary Reid

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.