Fax Software

Community Forums

This topic contains 5 replies, has 0 voices, and was last updated by  Anonymous 15 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2578

    theywood
    Member

    I am trying to send a Word file to Winfax 10.02 and have it process the fax using the Photo quality driver.

    Some code –

    Set objFax = CreateObject(“WinFax.SDKSend”)

    objFax.ShowSendScreen 0
    objFax.SetUseCover 0
    objFax.SetSubject pstrSubject
    objFax.SetCompany pstrCompany
    objFax.SetPriority 2

    objFax.SetCountryCode strPhoneCountry
    objFax.SetAreaCode strPhoneArea
    objFax.SetNumber strPhoneNumber
    objFax.SetTo pstrRecipient
    objFax.AddRecipient

    objFax.AddAttachmentFile strFileName ‘a Word file

    int1 = objFax.Send(1)

    Do While (objFax.IsEntryIDReady(0) <> 1)
    DoEvents
    Loop

    objFax.Done

    If I set ShowSendScreen = 1 then Winfax uses my default Printer Driver properties. If ShowSendScreen = 0 WinFax always uses the high speed driver. Any ideas?

    #4346

    Anonymous
    Member

    Do you have WinFax set to use the High Quality driver by default?

    #4347

    theywood
    Member

    No – I have the Photo quality driver set by default

    #4348

    Anonymous
    Member

    Ok the problem is that if you “attach” files it will always use the regular (high-speed) printer driver. It does not use the High Quality driver ever, because when the SDK was developed the High Quality driver did not exist. No changes were made to the SDK to directly support the high quality driver. Now if you simply print from an application (such as Word) you can use the high quality driver because you have to switch the WinFax driver first. There is a workaround for this, that is to rename the High Quality printer with the same name as the regular WinFax driver. In this case, all your output from WinFax will always use the High Quality driver.

    #4349

    theywood
    Member

    I have already tried that, but the fax is still not in photo quality mode. Does this have something to do with the printer port? I noticed the two WinFax printers have different port names.

    #4350

    Anonymous
    Member

    yes there are two ports because there are two seperate printer drivers.

    did you rename the driver like this:

    Rename the WinFax printer.

    Click Start, point to Settings, and click Printers.
    Select the WinFax printer, click File, and click Rename.
    Rename the file to OldWinFax
    Select the WinFax Photo Quality printer, click File, and click Rename.
    Rename the printer to WinFax.
    Close the Printer window.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.